Billboard(海報粘貼&簡單的線段樹)

題目來源:[NWPU][2014][TRN][13]線段樹第一講  G 題

http://vjudge.net/contest/view.action?cid=50850#problem/G




作者:npufz

題目:

G - Billboard
Time Limit:8000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information. 

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard. 

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi. 

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one. 

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university). 

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input

There are multiple cases (no more than 40 cases). 

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. 

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input

3 5 5 2 4 3 3 3
 

Sample Output

1 2 1 3 -1



代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
int high1;
typedef   struct rootpoint
{
    int   le,ri;
   int    mawid;
   int   mid()
    {
        return  (le+ri)/2;
    }
}   rootpoi;
rootpoi   tree[800050];
int built (int   root,int  l,int   r,int wid )
{
    if(l==r)
    {
        tree[root].le=l;
        tree[root].ri=r;
        tree[root].mawid=wid;
        return 0;
    }
    if(l!=r)
    {
        tree[root].le=l;
        tree[root].ri=r;
        tree[root].mawid=wid;
        built(root*2,l,(l+r)/2,wid);
        built(root*2+1,(l+r)/2+1,r,wid);
    }
return 0;
}
int  zhantie(int  root,int wid1)
{
    if(tree[root].mawid<wid1) return 0;
    if(tree[root].le==tree[root].ri&&tree[root].mawid>=wid1)
    {
        high1=tree[root].le;
        tree[root].mawid=tree[root].mawid-wid1;
        return 0;
    }
   else  if(tree[root*2].mawid>=wid1)
    {
        zhantie(root*2,wid1);
    }
    else
    {
        zhantie(root*2+1,wid1);
    }
  tree[root].mawid=max(tree[root*2].mawid,tree[root*2+1].mawid);
return 0;
}
int main()
{
    int  n,hi,wid,i,j,k,realhi;

     while(~scanf("%d%d%d",&hi,&wid,&n))
     {
        realhi=min(hi,n);
        built (1,1,realhi,wid);
        for(i=0;i<n;i++)
        {   int wid1;
            scanf("%d",&wid1);
            high1=-1;
            zhantie(1,wid1);
            printf("%d\n",high1);
        }
     }
return 0;
}

反思:

線段樹的構造主要是維護好子節點的變化對根節點的影響,看準輸入輸出很重要



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章