HDU-6213 Chinese Zodiac(map)

The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.
Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.
If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be 2 years. But if the signs of the couple is the same, the answer should be 12 years.
Input
The first line of input contains an integer T (1≤T≤1000) indicating the number of test cases.
For each test case a line of two strings describes the signs of Victoria and her husband.
Output
For each test case output an integer in a line.
Sample Input
3
ox rooster
rooster ox
dragon dragon
Sample Output
8
4
12
題意分析:這題的意思也很簡單,就是給定兩個生肖,讓計算這兩個生肖之間的最小差值,當然如果兩個生肖相同的話則差值爲12,不爲0.
解題思路:可以用map記錄每個生肖對應的序號,給定生肖的時候就可以根據序號來計算兩個生肖的差值。
AC代碼如下:

#include<stdio.h>
#include<map>
#include<math.h>
#include<algorithm>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
int main()
{
	map<string,int> m;
	string s1,s2;
	m["rat"]=1;m["ox"]=2;m["tiger"]=3;m["rabbit"]=4;
	m["dragon"]=5;m["snake"]=6;m["horse"]=7;m["sheep"]=8;
	m["monkey"]=9;m["rooster"]=10;m["dog"]=11;m["pig"]=12;
	int T;
	scanf("%d",&T);
	while(T--)
	{
		cin>>s1>>s2;
		if(m[s1]==m[s2])
			cout<<12<<endl;
		else
			cout<<(m[s2]-m[s1]+12)%12<<endl;
	}
	return 0;
 } 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章