LightOJ - 1079 Just another Robbery (概率 +揹包)

Just another Robbery

 

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

Note

For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That's why he has only option, just to rob rank 2.

題目鏈接:https://vjudge.net/problem/LightOJ-1079

題目大意:給出概率P和銀行個數n,給出每個銀行的錢和搶劫它被抓的概率,問在被抓概率小於P的情況下能獲得的最多的錢是多少

思路:可以轉化成揹包問題,dp[ i ] [ j ] 表示前i個銀行中,獲得的錢爲 j 的最小被抓概率

代碼:

#include<bits/stdc++.h>
using namespace std;
const int N=105;
int a[N];
double c[N],dp[N][N*N];
int main()
{
    int t,T=1;
    scanf("%d",&t);
    while(t--)
    {
        double p;
        int n,sum=0;
        scanf("%lf%d",&p,&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%lf",&a[i],&c[i]);
            sum+=a[i];
        }
        for(int i=1;i<=sum;i++) dp[0][i]=1.0;
        for(int i=1;i<=n;i++)
        {
            for(int j=sum;j>=1;j--)
            {
                if(j>=a[i]) dp[i][j]=min(dp[i-1][j],dp[i-1][j-a[i]]+(1-dp[i-1][j-a[i]])*c[i]);
                else dp[i][j]=dp[i-1][j];
            }
        }
        int ans=0;
        for(int i=1;i<=sum;i++)
            if(dp[n][i]<p)
            ans=i;
        printf("Case %d: %d\n",T++,ans);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章