poj 1753 Flip Game(dfs)_但是

Flip Game

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it’s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Choose any one of the 16 pieces.
Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb

Here “b” denotes pieces lying their black side up and “w” denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input
The input consists of 4 lines with 4 characters “w” or “b” each that denote game field position.

Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it’s impossible to achieve the goal, then write the word “Impossible” (without quotes).

Sample Input
bwwb
bbwb
bwwb
bwww

Sample Output
4


這題怎麼會想到O(n)的複雜度,dfs也就是2^16.但是還是沒有過,只是記錄。


#include <iostream>
#include <cstdio>
using namespace std;
#define N 10
#define inf 0x3f3f3f3f
int sum = inf;
char a[N][N];
int b[N][N];
bool f_d()
{
    for( int i = 0 ; i < 4 ; i ++ ){
        for( int j = 0 ; j < 4 ; j ++ ){
            if( b[i][j] != b[0][0] ) return false;
        }
    }
    return true;
}
void change( int x, int y )
{
    b[x][y] = !b[x][y];
    if( x - 1 >= 0 ) b[x-1][y] = !b[x-1][y];
    if( x + 1 < 4 )  b[x+1][y] = !b[x+1][y];
    if( y - 1 >= 0 ) b[x][y-1] = !b[x][y-1];
    if( y + 1 < 4 )  b[x][y+1] = !b[x][y+1];
//    應該不能用 ^=
}
void dfs( int x, int y, int m )
{
    if( sum < m ) return;
    if( f_d() ) sum = m;
    if( x > 3 || y > 3 ) return;

//    int nx, ny;
//    nx = (x + 1) % 4;
//    ny = y + ( x + 1 ) / 4;
//    dfs( nx, ny, m );
//    change( x, y );
//    dfs( nx, ny, m+1 );
//    change( x, y );
//    能a

    dfs( x+1, y, m );
    dfs( x, y+1, m );
    change( x, y );
    dfs( x+1, y, m+1 );
    dfs( x, y+1, m+1 );
    change( x, y );
//    沒有找出特殊樣例

//    dfs( x+1, y, m );
//    change( x+1, y );
//    dfs( x+1, y, m+1 );
//
//    dfs( x, y+1, m );
//    change( x, y+1 );
//    dfs( x, y+1, m+1 );
//
//    change( x, y+1 );
//    change( x+1, y );
//    忽略
    return;
}
int main()
{
    //freopen( "in.txt", "r", stdin );
    int i, j;
    for( i = 0 ; i < 4 ; i ++ ){
        scanf( "%s", &a[i] );
        for( j = 0 ; j < 4 ; j ++ ){
            b[i][j] = (a[i][j] == 'b' ? 0 : 1);
            //printf( "%c", a[i][j] );
        }//cout<<endl;
    }
    dfs( 0, 0, 0 );
    if( sum == inf ) cout<<"Impossible"<<endl;
    else cout<<sum<<endl;

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章