A Chess Game POJ - 2425------------------------------思維(樹形博弈+SG函數)

Let’s design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me… I will disturb the chesses and play it again.

Do you want to challenge me? Just write your program to show your qualification!
Input
Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.
Output
There is one line for each query, which contains a string “WIN” or “LOSE”. “WIN” means that the player taking the first turn can win the game according to a clever strategy; otherwise “LOSE” should be printed.
Sample Input
4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0
Sample Output
WIN
WIN
WIN
LOSE
WIN
Hint
Huge input,scanf is recommended.
Sponsor

解析:
尼姆博弈
因爲棋子移動幾格就代表着從某堆中取出幾個石頭
所以我們求出每個值的SG
詢問的時候只要判斷 他們SG值得異或爲0 那麼先手必敗,否則先手必勝

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
const int N=1e4+1000;
vector<int> G[N];
int n,m;
int sg[N];
bool vis[N];
int dfs(int u)
{
	if(sg[u]!=-1) return sg[u];
	int S[N];
	memset(S,0,sizeof S);
	for(int i=0;i<G[u].size();i++)
	{
		int x=G[u][i];
	 	dfs(x);
		S[sg[x]]=1;
	}
	for(int i=0;;i++) if(!S[i]) {
		sg[u]=i;
		break;
	}
	return sg[u] ;
}
int main()
{
	while(~scanf("%d",&n))
	{
		memset(sg,-1,sizeof sg);
		for(int i=0;i<n;i++) G[i].clear();
		for(int i=0;i<n;i++)
		{
			scanf("%d",&m);
			for(int j=0,x;j<m;j++)
			{
				scanf("%d",&x);
				G[i].push_back(x);
			}
		}
		for(int i=0;i<n;i++)  sg[i]=dfs(i);
		
		while(~scanf("%d",&m)&&m)
		{
			int sum=0;
			for(int i=0,x;i<m;i++)
			{
				cin>>x; 
				sum^=sg[x];
			}
			if(sum==0) cout<<"LOSE"<<endl;
			else cout<<"WIN"<<endl; 
		}
	}
 } 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章