HDU-1096 A+B for Input-Output Practice (VIII)

A+B for Input-Output Practice (VIII)

Problem Description

Your task is to calculate the sum of some integers.

 

 

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

 

 

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

 

 

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

 

 

Sample Output

10
15
6

Author

lcy

#include<bits/stdc++.h>
using namespace std;
int main(){
    int n;
    cin>>n;
    for(int j=0;j<n;++j){
        int i;
        long long s=0;
        int m;
        cin>>m;
        for(i=0;i<m;++i){
            int a;
            cin>>a;
            s+=a;
        }
        cout<<s<<endl;
        if(j!=n-1)
            cout<<endl;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章