PAT甲級1061. Dating (20)

Sherlock Holmes received a note with some strange strings: “Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm”. It took him only a minute to figure out that those strange strings are actually referring to the coded time “Thursday 14:04” – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter ‘D’, representing the 4th day in a week; the second common character is the 5th capital letter ‘E’, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is ‘s’ at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.
Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.
Output Specification:
For each test case, print the decoded time in one line, in the format “DAY HH:MM”, where “DAY” is a 3-character abbreviation for the days in a week – that is, “MON” for Monday, “TUE” for Tuesday, “WED” for Wednesday, “THU” for Thursday, “FRI” for Friday, “SAT” for Saturday, and “SUN” for Sunday. It is guaranteed that the result is unique for each case.
Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
Sample Output:
THU 14:04

day in the week:前兩個字符串的第一個位置相同的大寫字母
hour: 前兩個字符串第二個位置相同的字符
minute: 後兩個字符串第一個位置相同的英文字母的位置
以上都要注意範圍

#include <iostream>
using namespace std;
#include <string>

const char* week[]={"MON","TUE","WED","THU","FRI","SAT","SUN"}; 

int main(){
  string S1,S2,S3,S4;
  cin>>S1>>S2>>S3>>S4;

  //get the day in the week
  char Day;
  int i=0,j=0;
  for(i=0;i<S1.length()&&i<S2.length();i++){
    if(S1[i]==S2[i]&&(S1[i]>='A'&&S1[i]<='G')) { //注意範圍 
      Day=S1[i];
      break;   
    }  
  }
  //cout<<"i="<<i<<endl;
  //get Hour
  char Hour;
  for(j=i+1;j<S1.length()&&j<S2.length();j++){
    if(S1[j]==S2[j]&&((S1[j]>='A'&&S1[j]<='N')||(S1[j]>='0'&&S1[j]<='9'))) { //注意範圍 
        Hour=S1[j];
        break;  
    }
  }
//  cout<<"j="<<j<<endl;

  //get Minute
  int minute;
  for(int i=0;i<S3.length()&&i<S4.length();i++){
      if((S3[i]==S4[i])&&((S3[i]>='A'&&S3[i]<='Z')||(S3[i]>='a'&&S3[i]<='z'))){
      minute=i;
      break;
    }
  }

  cout<<week[Day-'A']<<" ";
    if(Hour>='0'&&Hour<='9') cout<<0<<Hour<<":";
    else cout<<10+Hour-'A'<<":";
  if(minute<10) cout<<"0";
  cout<<minute;

  return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章