PAT 甲級 1056 Mice and Rice (25 分) (模擬)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N
​P
​​ programmers. Then every N
​G
​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N
​G
​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N
​P
​​ and N
​G
​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N
​G
​​ mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N
​P
​​ distinct non-negative numbers W
​i
​​ (i=0,⋯,N
​P
​​ −1) where each W
​i
​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N
​P
​​ −1 (assume that the programmers are numbered from 0 to N
​P
​​ −1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:

5 5 5 2 5 5 5 3 1 3 5

題意: 給你NP個老鼠以及他們的重量W,每NG​個老鼠分一個組,不夠NG個數的單獨算一個組,比他們每個組的最大值,最大值進入下一輪的比較,同組其餘老鼠皆爲淘汰,並與其他組同時被淘汰的老鼠排名一致,求所有老鼠的排名。

思路:看着好像排個序就完事了,其實很麻煩,硬生生搞了一個小時,寫個博客記錄一下這個噁心的題,,,一開始沒想好要怎麼處理最後的那個排名,因爲它是每一層的失敗者排名相同,相當於,如果這一輪有x個人進入下一輪,那麼這些淘汰的人的排名就是x+1,剛開始把它想複雜了, 鄰接表都用上了,,服氣。。其他就沒什麼了,大體使用vector+結構體實現。

代碼:

#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<map>
#include<queue>
#include<iostream>
using namespace std;
#define inf 0x3f3f3f3f
const int N = 1005;
struct node
{
    int grade,id;
}peo[N];
int ans[N];
vector<node> a,b,x;
bool cmp(node x,node y)
{
    return x.grade>y.grade;
}
int main()
{
    int n,k,xx;
    cin>>n>>k;
    for(int i=0;i<n;i++)
        cin>>peo[i].grade,peo[i].id=i;
    for(int i=1;i<=n;i++)
        cin>>xx,a.push_back(peo[xx]);
    while(a.size()>1)  //a代表所有這一輪的人
    {
        x.clear();
        for(int i=0;i<a.size();i+=k)
        {
            b.clear();
            int sa=a.size();
            for(int j=i;j<min(sa,i+k);j++)
                b.push_back(a[j]);  //b裏面存儲一組人
            sort(b.begin(),b.end(),cmp);
            x.push_back(b[0]);  //x代表所有進了下一輪的人
        }
        for(int i=0;i<a.size();i++)  //記錄排名
        	ans[a[i].id]=x.size()+1;
        a=x;  //進行迭代
    }
    ans[a[0].id]=1;
    for(int i=0;i<n;i++)
    {
        if(i) cout<<" ";
        cout<<ans[i];
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章