PoJ 3252 Round Numbers 數位DP

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6


題目描述:

這題是要求a到b裏有多少round number(一下簡稱RN),RN就是二進制表示中0的個數大於等於1的個數的數


題解:

要求RN,顯然第一種方法是求小於一個數的數中有多少數滿足,這裏我們用組合數來求,比如現在在dfs的時候,現在的0和1的個數差值是0,還剩五個位置,現在可以隨意填,那麼我們就有C(5,3) + C(5,4)+C(5,5)
這是很顯然的一種解法,這裏說一種另外的解法

現在我們用sta來表示0的個數減去1的個數+32之後的這個數,爲什麼要+32呢,因爲如果先前的0比1少,但是後來如果0比較多的話,仍然可能讓他是一個round number,這樣+32只是爲了方便記憶化,畢竟數組下標不能爲負數,這對於我來說是新操作233,%%%

然後我們傳一個

int dfs( int pos, int sta, bool lead, bool limit ) 

其中sta的含義已經表示,pos表示當前討論的是哪一位,從小到大,lead表示是否求前導零,limit表示是否有限制

int dfs( int pos, int sta, bool lead, bool limit ) {
    if( pos == -1 ) return sta >= 32;
    if( !limit && !lead ) return dp[pos][sta];
    int up = limit ? a[pos] : 1;
    int ans = 0;
    for( register int i = 0; i <= up; i++ ) {
        if( lead && i == 0 ) ans += dfs( pos - 1, sta, lead, limit && i == up );
        else                 ans += dfs( pos - 1, sta + ( i == 0 ? 1 : -1 ), lead && i == 0, limit && i == up );
    }
    if( !limit && !lead ) dp[pos][sta] = ans;
    return ans;
}

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int dp[66][66], a[66]; 
int dfs( int pos, int sta, bool lead, bool limit ) { // sta表示0的個數減去1的個數 +32 
    if( pos == -1 ) return sta >= 32;
    if( !limit && !lead && dp[pos][sta] != -1 ) return dp[pos][sta];
    int up = limit ? a[pos] : 1;
    int ans = 0;
    for( register int i = 0; i <= up; i++ ) {
        if( lead && i == 0 ) ans += dfs( pos - 1, sta, lead, limit && i == up );
        else                 ans += dfs( pos - 1, sta + ( i == 0 ? 1 : -1 ), lead && i == 0, limit && i == up );         
    }
    if( !limit && !lead ) dp[pos][sta] = ans;
    return ans;
}

int solve( int n ) {
    int len = 0;
    while( n ) {
        a[len++] = n & 1;
        n >>= 1; 
    }
    return dfs( len - 1, 32, true, true );
} 

int main( ) { int a, b; memset( dp, -1, sizeof(dp) );   
    while( ~scanf( "%d%d", &a, &b ) ) 
        printf( "%d\n", solve( b ) - solve( a - 1 ) );
    return 0;
}

這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章