HDU2025--查找最大元素

Problem Description
對於輸入的每個字符串,查找其中的最大字母,在該字母后面插入字符串“(max)”。

Input
輸入數據包括多個測試實例,每個實例由一行長度不超過100的字符串組成,字符串僅由大小寫字母構成。

Output
對於每個測試實例輸出一行字符串,輸出的結果是插入字符串“(max)”後的結果,如果存在多個最大的字母,就在每一個最大字母后面都插入”(max)”。

Sample Input

abcdefgfedcba
xxxxx

Sample Output

abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)

代碼實現:

package newStart;

import java.util.Scanner;

public class P2025 {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        char c;
        while(sc.hasNext()){
            String line = sc.nextLine();
            c = line.charAt(0);
            for(int i=1;i<line.length();i++){
                if(c<line.charAt(i)){
                    c = line.charAt(i);//記錄當前的最大字符
                }
            }
            for(int i=0;i<line.length();i++){
                System.out.print(line.charAt(i));
                if(c==line.charAt(i)){//找出所有的最大字符,依次在後面加上"(max)"
                    System.out.print("(max)");
                }
            }
            System.out.println();
        }
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章