HDU - 4190 Distributing Ballot Boxes (二分 最大值最小)

HDU - 4190 Distributing Ballot Boxes (二分 最大值最小)

Today, besides SWERC’11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single resident of the country aged 18 or over is asked to vote in order to choose representatives for the Congress of Deputies and the Senate. You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory.
The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes to cities and the lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done.
The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum number of people assigned to vote in one box.
In the first case of the sample input, two boxes go to the fi rst city and the rest to the second, and exactly 100,000 people are assigned to vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes are assigned to the cities and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded of all in the optimal assignment.
Input
The fi rst line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot boxes. Each of the following N lines contains an integer a i,(1<=a i<=5,000,000), indicating the population of the i th city.
A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed.
Output
For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment.
Sample Input
2 7
200000
500000

4 6
120
2680
3400
200

-1 -1
Sample Output
100000
1700

題目大意:

有n個城市 ,每個城市有a[i]個人,有b個投票箱。想讓投票箱中最多的那個最小。
問 這個值是多少。

解題思路:

就是讓最大值最小。
二分這個答案,檢測答案的時候只要看以這個爲最大值,箱子夠不夠用就行,夠用那就讓 right左移,不夠用,就讓left右移

AC代碼:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 5e5+10;
int a[maxn];
int n,b;
bool judge(int x){
	int res = 0;
	for(int i=1;i<=n;i++){
		if(a[i]%x==0){
			res += (a[i]/x);
		}else{
			res += ((a[i]/x)+1);
		}
	}
	if(res<=b) return true;
	else return false;
}
int main(){
	while(scanf("%d%d",&n,&b)){
		if(n==-1&&b==-1) break;
		int max_num = 0;
		for(int i=1;i<=n;i++){
			scanf("%d",&a[i]);
			max_num = max(max_num,a[i]);
		}
		int left = 1;
		int right = max_num;
		int ans = max_num;
		while(left <= right){
			int mid = (left + right)/2;
			if(judge(mid)){
				ans = mid;
				right = mid-1;
			}else{
				left = mid+1;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章