LightOJ - 1422 Halloween Costumes 區間DP

Halloween Costumes
Time Limit: 2000MS Memory Limit: 32768KB 64bit IO Format: %lld & %llu

Description
Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input
Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N(1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integer ci(1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output
For each case, print the case number and the minimum number of required costumes.

Sample Input
2
4
1 2 1 2
7
1 2 1 1 3 2 1
Sample Output
Case 1: 3
Case 2: 4
Source
Problem Setter: Manzurur Rahman Khan

Special Thanks: Jane Alam Jan (Solution, Dataset)

題意:給定N天Party分別要穿的衣服(種類)。

限制條件:1穿過的衣服脫下後不能再穿;2每新穿一件ANS+1;3對於第i天需要穿的衣服costume

若第j(j<i)天已穿上該服裝且至今未脫,則可脫去(j , i-1 ]天的衣服 ,從而參加該天Party。

問從第一個Party開始,最少需要準備幾件。

思路:對於區間問題,(其實是專題分類在dp)選擇區間DP。

設dp[ i ] [ j ]  意爲從第 i 天到 第 j  天的最少需要準備的件數。

具體分析: 對於第 j  天,無非兩種情況 1:再多穿一件。 即dp[ i ][ j ] = dp[ i ] [ j -1] +1

2:  若從第 i 天 到 第  J - 1 天 存在相同衣服 ,即 costume[ j ] = costume [ mid ] 則dp[ i ] [ j ] = dp[ i ] [ mid ] + dp [ mid+1] [ j -1 ] ;

基礎區間DP

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
#define max(a,b) (a>b?a:b)
#define CLR(arr,x) memset(arr,x,sizeof(arr))
const int maxn = 100 +100;
const int inf = 1<<30 ;
int main() {
    int n ,ncase ,text = 1 ;
    int a[maxn],dp[maxn][maxn] ;
    cin >> ncase ;
    while(ncase--) {
        scanf("%d",&n) ;
        for(int i = 1 ; i <= n ; ++i ) {
            scanf("%d",&a[i]);
        }
        CLR(dp,0) ;
        for( int i = 1 ;i <= n ; ++i ) { 
            dp[i][i] = 1 ;
        }
       for(int j = 2 ; j <= n ; ++j) {
        for(int i = 1; i < j ; ++i) {
            dp[i][j] = dp[i][j-1]+1;
            for(int k = i; k < j; ++k) {
                    if(a[k] == a[j])
                dp[i][j] = min(dp[i][j],dp[i][k]+dp[k+1][j-1]) ;
            }
        }
       }
        printf("Case %d: %d\n",text++,dp[1][n]) ;
    }
    return 0 ;
}

 




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章