acm hdu p1021 Fibonacci Again java解答 水水 找規律

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44697    Accepted Submission(s): 21341


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 


Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 


Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 


Sample Input
0 1 2 3 4 5
 


Sample Output
no no yes no no no


根據前輩們找的規律   8*k+2或8*k+6   k爲自然數


package HDU;
import java.util.Scanner;
public class p1021 {
 public static void main(String[] args) {
     Scanner sc=new Scanner(System.in);
      while(sc.hasNext()){
    	  int n=sc.nextInt();
    	  if(n%8==2||n%8==6){
    		  System.out.println("yes");
    	  }else{
    		 System.out.println("no"); 
    	  }
      }
     
    }

}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章