HDU 5630 Rikka with Chess(翻棋子)

Rikka with Chess

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 639 Accepted Submission(s): 541


Problem Description
Yuta gives Rikka a chess board of size n×m.

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors.

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa.

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.

Input
The first line contains a number T(T10) ——The number of the testcases.

Each testcase contains two numbers n,m(n109,m109).

Output
For each testcase, print a single number which represents the answer.

Sample Input
3 1 2 2 2 3 3

Sample Output
1 2 2

Source

/*
思路:剛看到題目被嚇到,然後畫圖猜,發現這個規律,所以不要被題目嚇到.. 
*/
#include<iostream>
using namespace std;
int main()
{  
    int n,m,t;
    cin>>t;
    while(t--){
    	cin>>n>>m;
    	cout<<n/2+m/2<<endl;;
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章