HDU 2088 Box of Bricks

Box of Bricks

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10779    Accepted Submission(s): 3656


Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I've built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
 

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.
 

Output
For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.
 

Sample Input
6 5 2 4 1 7 5 0
 

Sample Output
5
 

Author
qianneng
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1022 1024 1701 2105 1219 
 

Statistic | Submit | Discuss | Note

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    int a[60];
    int k=0;
    while(cin>>n&&n)
    {
        if(k)
        {
            cout<<endl;
        }
        int i;
        int sum=0,ave=0,suma=0;
        for(i=0;i<n;i++)
        {
            cin>>a[i];
            sum += a[i];
        }
        ave = sum/n;
        for(i=0;i<n;i++)
        {
            suma+=abs(a[i]-ave);
        }
        cout<<suma/2<<endl;
        k++;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章