HDU6201(spfa)

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 842    Accepted Submission(s): 411


Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is ai yuan in it city. Kelukin will take taxi, whose price is 1yuan per km and this fare cannot be ignored.
There are n1 roads connecting n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
 

Input
The first line contains an integer T (1T10) , the number of test cases.
For each test case:
first line contains an integer n (2n100000) means the number of cities;
second line contains n numbers, the ith number means the prices in ith city; (1Price10000)
then follows n1 lines, each contains three numbers x, y and z which means there exists a road between x and y, the distance is zkm (1z1000).
 

Output
For each test case, output a single number in a line: the maximum money he can get.
 

Sample Input
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
 

Sample Output
8
 

解題思路:我們增加一個源點,讓所有點與這個源點相連,邊權爲a[i], 增加一個匯點,讓所有點與這個匯點相連,邊權爲-a[i],然後我們求一條從源點到匯點的最長路徑就行,因爲涉及到負邊,所以我們用spfa就行。


#include <bits/stdc++.h>
using namespace std;
const int maxn = 100000 + 100;
int n;
int d[maxn];
bool visit[maxn];
int inf = 0x3f3f3f3f;
struct node{
    int v;
    int w;
    node(int _v = 0, int _w = 0){
        v = _v;
        w = _w;
    }
};
queue<node> q;
vector<pair<int ,int> > g[maxn];
int spfa()
{
   memset(d, -inf, sizeof(d));
   memset(visit, false, sizeof(visit));
   while(!q.empty()) q.pop();
   d[0] = 0;
   q.push(node(0, 0));
   while(!q.empty())
   {
       node nx = q.front();
       q.pop();
       int v = nx.v;
       visit[v] = false;
       for(int i = 0; i < g[v].size(); i++)
       {
           int u = g[v][i].first;
           int ww = g[v][i].second;
           if(d[v] + ww > d[u] && u != 0)
           {
               d[u] = d[v] + ww;
               if(visit[u]) continue;
               visit[u] = true;
               q.push(node(u, d[u]));
           }
       }
   }
   if(d[n + 1] > 0) return d[n + 1];
   else return 0;
}
void init()
{
    for(int i = 0; i <= n + 1; i++)
    {
        g[i].clear();
    }
}
int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        init();
        int u, v, w;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &w);
            g[0].push_back(make_pair(i, w));
            g[i].push_back(make_pair(0, w));
            g[n + 1].push_back(make_pair(i, -w));
            g[i].push_back(make_pair(n + 1, -w));
        }
        for(int i = 1; i < n; i++)
        {
            scanf("%d%d%d", &u, &v, &w);
            g[u].push_back(make_pair(v, -w));
            g[v].push_back(make_pair(u, -w));
        }
        printf("%d\n", spfa());
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章