POJ 1611 The Suspects 【並查集】

題面:

evere acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

題目大意:

現在有n個人,編號爲0-n。有m個團體,每個團體k個人。已知0號是有嫌疑,所以與0號是一個團體的都有嫌疑。問有多少個有嫌疑的人。

大致思路:

很明顯的思路,把所有提到的人利用並查集進行集合判斷。然後查找和0同一集合的人就行了。現在存在一種情況:提到的人數比較少,而n又比較大。這個時候從1-n掃一遍就很浪費時間。所以利用set,將提到的人的編號保存起來。然後只需要找提到的人就行了。

代碼:

#include<iostream>
#include<algorithm>
#include<set>
#include<cstdlib>
using namespace std;
const int maxn=3e4+10;
int father[maxn];
int Find(int x)
{
    if(x!=father[x])
        father[x]=Find(father[x]);
    return father[x];
}
void Union(int x,int y)
{
    x=Find(x);
    y=Find(y);
    if(x!=y)
        father[x]=y;
    return ;
}
int main()
{
    ios::sync_with_stdio(false);
    //freopen("in.txt","r",stdin);
    set<int> s;
    int n,m,k,cnt,x,y;
    while(cin>>n>>m&&(n||m))
    {
        s.clear();
        cnt=1;
        for(int i=0;i<n;++i)
            father[i]=i;
        for(int i=0;i<m;++i){
            cin>>k>>x;
            s.insert(x);//將讀到的插入set
            for(int i=1;i<k;++i){
                cin>>y;
                s.insert(y);
                Union(x,y);
            }
        }
        int key=Find(0);
        set<int>::iterator it;
        for(it=s.begin();it!=s.end();++it){//將set中的元素掃一遍
            if(key==Find(*it)&&(*it))//父節點相同且元素不爲0,防止重複計算
                cnt++;
        }
        cout<<cnt<<endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章