1424: Coin Change dp

 

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
3s 8192K 579 188 Standard

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

 


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

 


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

 

11
26

Sample Output

4
13



#include <stdio.h>
#include <string.h>
int v[5]={1,5,10,25,50};
int d[100000];
int main ()
{
int n;
while(scanf("%d",&n)==1)
{
memset(d,0,sizeof(d));
int tot=0;
d[0]=1;
for(int i=0;i<5;i++) //v[i]在外邊可以去掉重複情況
for(int j=0;j<=n;j++)
if(j-v[i]>=0) d[j]+=d[j-v[i]]; //dp方程
printf("%d/n",d[n]);
}
return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章