POJ Period 1691(kmp)

Period
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 16765   Accepted: 8069

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source


題意:求每個點是否存在循環節,

分析:求出next[ ]數組,如果 i%(i-next[i])==0 && next[i]!=0則有循環節次數i/(i-next[i]) ,循環節長度i-next[i]

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;
#define maxx 1123456
int next[maxx];
char t[maxx];
void get_next(char t[])
{
    int l=strlen(t);
    int i=0,j=-1;
    next[0]=-1;
    while(i<l)
    {
        if(j==-1 || t[i]==t[j])
        {
            i++;j++;next[i]=j;
        }
        else
        {
            j=next[j];
        }
    }
}
int main()
{
    int n,m,i,j;
    int ll=1;
    while(scanf("%d",&n)&&n)
    {
        scanf("%s",t);
        get_next(t);
        int l=n;
        printf("Test case #%d\n",ll++);
        for(i=2;i<=l;i++)
        {
        if(i%(i-next[i])==0 && next[i]!=0)
        printf("%d %d\n",i,i/(i-next[i]));
        }
        printf("\n");
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章