HDU 4027 Can you answer these queries?(線段樹求區間和)

                     Can you answer these queries?

 


A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help. 
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line. 

Notice that the square root operation should be rounded down to integer.
InputThe input contains several test cases, terminated by EOF. 
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000) 
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000) 
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive. 
OutputFor each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case. Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8
Sample Output
Case #1:
19
7
6

題意:我軍的祕密武器對敵軍戰艦區間性造成傷害,每次都會使一整排的戰艦收的傷害,並且每個戰艦的防護罩的值會變回原來的平方根,向下取平方根,m的操作行數,第一個0爲攻擊x-y區間的戰艦,第一個爲1表示詢問x-y區間內的防護罩總值

思路:一開始沒有進行優化超時了,當防護罩的值小於等於1時,不用再繼續進行平方根了,某個區間都是小於等於1的話,那這個區間也不用再繼續平方根了

再利用線段樹修改和求和就好了

上代碼

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<string>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1
#define maxn 100010
ll sum[maxn << 2];
bool visit[maxn << 2];
void pushup(int rt)
{
	sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
	visit[rt] = visit[rt << 1] && visit[rt << 1 | 1];//如果都不能平方根,勢必visit[rt]也不能平方根
}
void build(int l, int r, int rt)
{
	if (l == r)
	{
		scanf("%lld", &sum[rt]);
		return;
	}
	int m = (l + r) >> 1;
	build(ls);
	build(rs);
	pushup(rt);
}
void updata(int L, int R, int l, int r, int rt)
{
	if (l == r)
	{
		sum[rt] = sqrt(sum[rt]);
		if (sum[rt] <= 1)//小於等於1已經是不能在平方根了
			visit[rt] = true;
		return;
	}
	int m = (l + r) >> 1;
	if (m >= L && !visit[rt])
		updata(L, R, ls);
	if (R>m && !visit[rt])
		updata(L, R, rs);
	pushup(rt);//向上更新節點
}
ll query(int L, int R, int l, int r, int rt)
{
	if (L <= l&&R >= r)
		return sum[rt];
	int m = (l + r) >> 1;
	ll ans = 0;
	if (m >= L)
		ans += query(L, R, ls);
	if (R>m)
		ans += query(L, R, rs);
	return ans;
}
int main()
{
	//freopen("Text.txt","r",stdin);
	int n, q, st, nd, t;
	int k = 1;
	while (scanf("%d", &n) != EOF)
	{
		memset(visit, false, sizeof(visit));
		printf("Case #%d:\n", k++);
		build(1, n, 1);
		scanf("%d", &q);
		while (q--)
		{
			scanf("%d%d%d", &t, &st, &nd);
			if (st>nd)
				swap(st, nd);//這是坑,天坑
			if (t == 0)
				updata(st, nd, 1, n, 1);
			else
				printf("%lld\n", query(st, nd, 1, n, 1));
		}
		printf("\n");
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章