HDU 6198 number number number(斐波那契)

number number number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 180 Accepted Submission(s): 120

Problem Description

We define a sequence F:

⋅ F0=0,F1=1;
⋅ Fn=Fn−1+Fn−2 (n≥2).

Give you an integer k, if a positive number n can be expressed by
n=Fa1+Fa2+…+Fak where 0≤a1≤a2≤⋯≤ak, this positive number is mjf−good. Otherwise, this positive number is mjf−bad.
Now, give you an integer k, you task is to find the minimal positive mjf−bad number.
The answer may be too large. Please print the answer modulo 998244353.

Input

There are about 500 test cases, end up with EOF.
Each test case includes an integer k which is described above. (1≤k≤109)

Output

For each case, output the minimal mjf−bad number mod 998244353.

Sample Input

1

Sample Output

4

Source

2017 ACM/ICPC Asia Regional Shenyang Online
題意:問k個斐波那契數的和不能表示的數的最小值。
題解:打表找規律得
k==1, ans=4,ans=f[5]-1;
k==2,ans=12,ans=f[7]-1;
……
矩陣快速冪求斐波那契數列即可。
代碼:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
#define mod 998244353
#define ll long long int
typedef struct Matrix
{
    ll mat[2][2];
}matrix;
matrix A,B;
Matrix matrix_mul(matrix a,matrix b)
{
    matrix c;
    memset(c.mat,0,sizeof(c.mat));
    ll i,j,k;
    for(ll i=0;i<2;i++)
    {
        for(ll j=0;j<2;j++)
        {
            for(ll k=0;k<2;k++)
            {
                c.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
                c.mat[i][j]%=mod;
            }
        }
    }
    return c;
}
Matrix matrix_quick_power(matrix a,ll k)//矩陣快速冪0.0
{
    matrix b;
    memset(b.mat,0,sizeof(b.mat));
    for(ll i=0;i<2;i++)
    b.mat[i][i]=1;//單位矩陣b
    while(k)
    {
        if(k%2==1)
        {
            b=matrix_mul(a,b);
            k-=1;
        }
        else
        {
            a=matrix_mul(a,a);
            k/=2;
        }
    }
    return b;
}
int main()
{
    ll n;
    while(cin>>n)
    {
        n=(n-1)*2+5;
        if(n==-1)break;
        A.mat[0][0]=1;A.mat[0][1]=1;
        A.mat[1][0]=1;A.mat[1][1]=0;
        B=matrix_quick_power(A,n);
        cout<<(B.mat[0][1]-1+mod)%mod<<endl;
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章