HDU 6197 array array array

array array array
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 192 Accepted Submission(s): 120

Problem Description

One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo’s path to escape from the museum. But Kiddo didn’t want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: “I have an array A and a number k, if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. ” Conan: “emmmmm…” Now, Conan seems to be in trouble, can you help him?

Input

The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2…An.
1≤T≤20
1≤n≤105
0≤k≤n
1≤Ai≤105

Output

For each test case, please output “A is a magic array.” if it is a magic array. Otherwise, output “A is not a magic array.” (without quotes).

Sample Input

3
4 1
1 4 3 7
5 2
4 1 3 1 2
6 1
1 4 3 5 4 6

Sample Output

A is a magic array.
A is a magic array.
A is not a magic array.

Source

2017 ACM/ICPC Asia Regional Shenyang Online
題意:將一個序列刪除k個字符後,能否變成一個非嚴格遞增或者非嚴格遞減的序列。
題解:先求序列非嚴格遞增或者非嚴格遞減的長度,然後取最大,如果k>=n-max就能。
代碼:

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<vector>
#include<queue>
#include<set>
#include<algorithm>
#include<map>
#include<math.h>
using namespace std;
typedef long long int ll;
typedef pair<int,int>pa;
const int N=1e6+100;
const int mod=1e9+7;
const ll INF=1e18;
int read()
{
    int x=0;
    char ch = getchar();
    while('0'>ch||ch>'9')ch=getchar();
    while('0'<=ch&&ch<='9')
    {
        x=(x<<3)+(x<<1)+ch-'0';
        ch=getchar();
    }
    return x;
}
/***********************************************************/
int t,n,k;
int a[N],d[N];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        memset(d,0,sizeof(d));
        for(int i=1; i<=n; i++) scanf("%d",&a[i]);
        int len1=1;
        d[1]=a[1];
        for(int i=2; i<=n; i++)
        {
            if(a[i]>=d[len1])
                d[++len1]=a[i];
            else
            {
                int j=upper_bound(d+1,d+1+len1,a[i])-d;
                d[j]=a[i];
            }
        }
        memset(d,0,sizeof(d));
        reverse(a+1,a+1+n);
        int len2=1;
        d[1]=a[1];
        for(int i=2; i<=n; i++)
        {
            if(a[i]>=d[len2])
                d[++len2]=a[i];
            else
            {
                int j=upper_bound(d+1,d+1+len2,a[i])-d;
                d[j]=a[i];
            }
        }
        if(k>=n-max(len1,len2)&&k<=n)
            puts("A is a magic array.");
        else
            puts("A is not a magic array.");
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章