POJ 1350 Cabric Number Problem

題目鏈接:http://poj.org/problem?id=1350
Cabric Number Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11123 Accepted: 3422
Description

If we input a number formed by 4 digits and these digits are not all of one same value, then it obeys the following law. Let us operate the number in the following way:
(1) Arrange the digits in the way from bigger to smaller, such that it forms the biggest number that could be made from these 4 digits;
(2) Arrange the digits in the way from smaller to bigger, such that it forms the smallest number that could be made from these 4 digits (If there is 0 among these 4 digits, the number obtained may be less than four digits);
(3) Find the difference of these two numbers that is a new four digital number.
Repeat the above process, we can finally always get the result 6174 or 0.
Please write the program to realize the above algorithm.
Input

Each case is a line of an integer.-1 denotes the end of input.
Output

If the integer is formed exactly by 4 digits and these digits are not all of one same value, then output from the program should show the procedure for finding this number and the number of repetition times. Otherwise output “No!!”.
Sample Input

5364
2221
4444
-1
Sample Output

N=5364:
6543-3456=3087
8730-378=8352
8532-2358=6174
Ok!! 3 times
N=2221:
2221-1222=999
999-999=0
Ok!! 2 times
N=4444:
No!!
Source

Xi’an 2002

模擬題

題意:就是首先給你一個四位數,如果這個四位數的每一位都相等,直接輸出No!!
否則的話,就用這四位數字組成的最大的數減去最小的數,直到差爲6174或者是爲0的時候才結束,最後按照特定的格式並且將變換的次數輸出。

我的代碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[8];
void fenjie(int n)
{
    a[0]=n%10;
    n=n/10;
    a[1]=n%10;
    n/=10;
    a[2]=n%10;
    n/=10;
    a[3]=n%10;
}
int main()
{
    int n;
    //fenjie(6543);
    //for(int i=0;i<4;i++)
        //printf("%d ",a[i]);
    while(~scanf("%d",&n))
    {
        if(n==-1)
            break;
        printf("N=%d:\n",n);
        fenjie(n);
        if(a[0]==a[1]&&a[1]==a[2]&&a[2]==a[3]||n<1000||n>9999)
        {
            printf("No!!\n");
            continue;
        }
        int s=-1,d=0;
        while(s!=0&&s!=6174)
        {
            fenjie(n);
            int len=0,flag=0;
            for(int i=3;i>=0;i--)
                if(a[i]!=0)
                len++;
            for(int i=0; i<len-1; i++)
                if(a[i]!=a[i+1])
                {
                    flag=1;
                }
            if(flag==0)
            {
                d++;
                int tt=a[3]*1000+a[2]*100+a[1]*10+a[0];
                printf("%d-%d=0\n",tt,tt);
                break;
            }
            sort(a,a+4);
            int s1,s2;
            if(a[2]==0)
            {
                s1=a[3];
                s2=a[3]*1000+a[2]*100+a[1]*10+a[0];
            }
            else if(a[1]==0)
            {
                s1=a[2]*10+a[3];
                s2=a[3]*1000+a[2]*100+a[1]*10+a[0];
            }
            else if(a[0]==0)
            {
                s1=a[1]*100+a[2]*10+a[3];
                s2=a[3]*1000+a[2]*100+a[1]*10+a[0];
            }
            else
            {
                s1=a[0]*1000+a[1]*100+a[2]*10+a[3];
                s2=a[3]*1000+a[2]*100+a[1]*10+a[0];
            }
            s=s2-s1;
            n=s;
            printf("%d-%d=%d\n",s2,s1,s2-s1);
            d++;
        }
        printf("Ok!! %d times\n",d);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章