Dynamic Multipoint ***


221540665.jpg



-------------------------------總部:北 京-------------------------------


R5(config)#interface fastEthernet 0/0

R5(config-if)#ip address 10.1.1.5 255.255.255.0

R5(config-if)#no sh


R5(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.1


R1(config)#interface fastEthernet 0/0

R1(config-if)#ip address 10.1.1.1 255.255.255.0

R1(config-if)#no sh


R1(config)#interface fastEthernet 1/0

R1(config-if)#ip address 12.1.1.1 255.255.255.0

R1(config-if)#no sh


R1(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 1/0





---------------------------------Internet---------------------------------


R2(config)#interface fastEthernet 0/0

R2(config-if)#ip address 23.1.1.2 255.255.255.0

R2(config-if)#no sh


R2(config)#interface fastEthernet 0/1

R2(config-if)#ip address 24.1.1.2 255.255.255.0

R2(config-if)#no sh


R2(config)#interface fastEthernet 1/0

R2(config-if)#ip address 12.1.1.2 255.255.255.0

R2(config-if)#no sh


R2(config)#service dhcp

R2(config)#ip dhcp pool NET23

R2(dhcp-config)#network 23.1.1.0 255.255.255.0

R2(dhcp-config)#default-router 23.1.1.2


R2(config)#ip dhcp excluded-address 23.1.1.2


R2(config)#interface fastEthernet 0/1

R2(config-if)#ip address 24.1.1.2 255.255.255.0

R2(config-if)#no sh





-------------------------------加盟店:上海-------------------------------


R3(config)#interface fastEthernet 0/0

R3(config-if)#ip address dhcp


R3(config)#interface fastEthernet 0/1

R3(config-if)#ip address 192.168.1.3 255.255.255.0

R3(config-if)#no sh


R6(config)#interface fastEthernet 0/1

R6(config-if)#ip address 192.168.1.4 255.255.255.0

R6(config-if)#no sh


R6(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.3





-------------------------------加盟店:廣州-------------------------------


R4(config)#interface fastEthernet 0/1

R4(config-if)#ip address 24.1.1.3 255.255.255.0

R4(config-if)#no sh



R4(config)#interface fastEthernet 0/0

R4(config-if)#ip address 172.16.1.4 255.255.255.0

R4(config-if)#no sh


R4(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/1


R7(config)#interface fastEthernet 0/0

R7(config-if)#ip address 172.16.1.5 255.255.255.0

R7(config-if)#no sh


R7(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.4





-----------------------------------DM***----------------------------------


R1(config)#crypto isakmp policy 1

R1(config-isakmp)#authentication pre-share

R1(config-isakmp)#encryption 3des

R1(config-isakmp)#hash sha

R1(config-isakmp)#group 2


R1(config)#crypto isakmp key 0 cisco address 0.0.0.0

R1(config)#crypto ipsec transform-set ZB esp-3des esp-sha-hmac

R1(cfg-crypto-trans)#mode tunnel


R1(config)#crypto ipsec profile BJ

R1(ipsec-profile)#set transform-set ZB


R1(config)#interface tunnel 1

R1(config-if)#bandwidth 1000

R1(config-if)#ip address 100.1.1.1 255.255.255.0

R1(config-if)#ip mtu 1400

R1(config-if)#ip nhrp authentication cisco

R1(config-if)#ip nhrp map multicast dynamic

R1(config-if)#ip nhrp network-id 1

R1(config-if)#no ip split-horizon eigrp 1

R1(config-if)#tunnel source fastEthernet 1/0

R1(config-if)#tunnel mode gre multipoint

R1(config-if)#tunnel key 10000

R1(config-if)#tunnel protection ipsec profile BJ




R3(config)#crypto isakmp policy 1

R3(config-isakmp)#authentication pre-share

R3(config-isakmp)#encryption 3des

R3(config-isakmp)#hash sha

R3(config-isakmp)#group 2


R3(config)#crypto isakmp key 0 cisco address 0.0.0.0

R3(config)#crypto ipsec transform-set JMD:SH esp-3des esp-sha-hmac

R3(cfg-crypto-trans)#mode tunnel


R3(config)#crypto ipsec profile SH

R3(ipsec-profile)#set transform-set JMD:SH


R3(config)#interface tunnel 3

R3(config-if)#bandwidth 1000

R3(config-if)#ip address 100.1.1.3 255.255.255.0

R3(config-if)#ip mtu 1400

R3(config-if)#ip nhrp authentication cisco

R3(config-if)#ip nhrp map 100.1.1.1 12.1.1.1

R3(config-if)#ip nhrp map multicast 12.1.1.1

R3(config-if)#ip nhrp network-id 1

R3(config-if)#ip nhrp nhs 100.1.1.1

R3(config-if)#tunnel source fastEthernet 0/0

R3(config-if)#tunnel mode gre multipoint

R3(config-if)#tunnel key 10000

R3(config-if)#tunnel protection ipsec profile SH




R3#ping 100.1.1.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 100.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 340/409/452 ms



R3#ping 10.1.1.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)





R4(config)#crypto isakmp policy 1

R4(config-isakmp)#authentication pre-share

R4(config-isakmp)#encryption 3des

R4(config-isakmp)#hash sha

R4(config-isakmp)#group 2


R4(config)#crypto isakmp key 0 cisco address 0.0.0.0

R4(config)#crypto ipsec transform-set JMD:GZ esp-3des esp-sha-hmac

R4(cfg-crypto-trans)#mode tunnel


R4(config)#crypto ipsec profile GZ

R4(ipsec-profile)#set transform-set JMD:GZ


R4(config)#interface tunnel 4

R4(config-if)#bandwidth 1000

R4(config-if)#ip address 100.1.1.4 255.255.255.0

R4(config-if)#ip mtu 1400

R4(config-if)#ip nhrp authentication cisco

R4(config-if)#ip nhrp map 100.1.1.1 12.1.1.1

R4(config-if)#ip nhrp map multicast 12.1.1.1

R4(config-if)#ip nhrp network-id 1

R4(config-if)#ip nhrp nhs 100.1.1.1

R4(config-if)#tunnel source fastEthernet 0/1

R4(config-if)#tunnel mode gre multipoint

R4(config-if)#tunnel key 10000

R4(config-if)#tunnel protection ipsec profile GZ




R4#ping 100.1.1.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 100.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 332/411/460 ms


R4#ping 10.1.1.5


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.5, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)





-----------------------------------EIGRP----------------------------------


R1(config)#router eigrp 1

R1(config-router)#no auto-summary

R1(config-router)#network 10.1.1.1 0.0.0.0

R1(config-router)#network 100.1.1.1 0.0.0.0


R3(config)#router eigrp 1

R3(config-router)#no auto-summary

R3(config-router)#network 192.168.1.3 0.0.0.0

R3(config-router)#network 100.1.1.3 0.0.0.0




R1#ping 192.168.1.4


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 468/630/764 ms




R5#traceroute 192.168.1.4


Type escape sequence to abort.

Tracing the route to 192.168.1.4


1 10.1.1.1 208 msec 216 msec 212 msec

2 100.1.1.3 612 msec 612 msec 624 msec

3 192.168.1.4 616 msec 824 msec *




R4(config)#router eigrp 1

R4(config-router)#no auto-summary

R4(config-router)#network 172.16.1.4 0.0.0.0

R4(config-router)#network 100.1.1.4 0.0.0.0




R7#traceroute 10.1.1.5


Type escape sequence to abort.

Tracing the route to 10.1.1.5


1 172.16.1.4 196 msec 196 msec 196 msec

2 100.1.1.1 844 msec 708 msec 648 msec

3 10.1.1.5 840 msec 1032 msec 840 msec





--------------------------spoke-to-spoke Tunnel---------------------------


R7#traceroute 192.168.1.4


Type escape sequence to abort.

Tracing the route to 192.168.1.4


1 172.16.1.4 272 msec 272 msec 280 msec

2 100.1.1.1 516 msec 836 msec 624 msec

3 100.1.1.3 956 msec 1292 msec 1220 msec

4 192.168.1.4 1152 msec 1164 msec 1120 msec




R1(config)#interface tunnel 1

R1(config-if)#no ip next-hop-self eigrp 1




R7#traceroute 192.168.1.4


Type escape sequence to abort.

Tracing the route to 192.168.1.4


1 172.16.1.4 272 msec 208 msec 204 msec

2 100.1.1.3 556 msec 408 msec 684 msec

3 192.168.1.4 768 msec 628 msec 712 msec






發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章