多區域下實現BGP互聯

      這段時間比較忙,所以很多實驗就沒花時間寫詳細的講解,直接把 SHOW RUN的內容貼上來了,還請大家海涵!!!
      閒話少說,上圖
 
以下是配置
 
r1#SHOW run
Building configuration...
Current configuration : 1146 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
no ip domain lookup
!
!        
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 12.12.12.1 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 passive-interface Loopback0
 network 1.1.1.0 0.0.0.255
 network 12.12.12.0 0.0.0.255
 no auto-summary
!
router bgp 1
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 network 12.12.12.0 mask 255.255.255.0
 neighbor 12.12.12.2 remote-as 234
 neighbor 12.12.12.2 ebgp-multihop 2
 neighbor 12.12.12.2 update-source Ethernet0/0
 no auto-summary
!
ip http server
!
!
!
cdp timer 5
cdp holdtime 10
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end
 

r2#show run
Building configuration...
Current configuration : 1400 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
no ip domain lookup
!
!        
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Ethernet0/0
 ip address 12.12.12.2 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 23.23.23.2 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!        
router eigrp 234
 passive-interface Loopback0
 network 12.12.12.0 0.0.0.255
 network 23.23.23.0 0.0.0.255
 no auto-summary
!
router bgp 234
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 network 12.12.12.0 mask 255.255.255.0
 network 23.23.23.0 mask 255.255.255.0
 neighbor 12.12.12.1 remote-as 1
 neighbor 12.12.12.1 ebgp-multihop 2
 neighbor 12.12.12.1 update-source Ethernet0/0
 neighbor 23.23.23.3 remote-as 234
 neighbor 23.23.23.3 update-source Ethernet0/1
 neighbor 23.23.23.3 next-hop-self
 neighbor 34.34.34.4 remote-as 234
 neighbor 34.34.34.4 update-source Ethernet0/1
 neighbor 34.34.34.4 next-hop-self
 no auto-summary
!        
ip http server
!
!
!
cdp timer 5
cdp holdtime 10
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end
 

r3#show run
Building configuration...
Current configuration : 1231 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
no ip domain lookup
!
!        
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 23.23.23.3 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 34.34.34.3 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!        
router eigrp 234
 network 23.23.23.0 0.0.0.255
 network 34.34.34.0 0.0.0.255
 no auto-summary
!
router bgp 234
 no synchronization
 bgp log-neighbor-changes
 network 23.23.23.0 mask 255.255.255.0
 network 34.34.34.0 mask 255.255.255.0
 neighbor 23.23.23.2 remote-as 234
 neighbor 23.23.23.2 update-source Ethernet0/0
 neighbor 23.23.23.2 next-hop-self
 neighbor 34.34.34.4 remote-as 234
 neighbor 34.34.34.4 update-source Ethernet0/1
 neighbor 34.34.34.4 next-hop-self
 no auto-summary
!
ip http server
!
!
!
cdp timer 5
cdp holdtime 10
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end
 
r4#show run
Building configuration...
Current configuration : 1371 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
no ip domain lookup
!
!        
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface Ethernet0/0
 ip address 34.34.34.4 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 ip address 45.45.45.4 255.255.255.0
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!        
router eigrp 234
 network 34.34.34.0 0.0.0.255
 network 45.45.45.0 0.0.0.255
 no auto-summary
!
router bgp 234
 no synchronization
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 network 34.34.34.0 mask 255.255.255.0
 network 45.45.45.0 mask 255.255.255.0
 neighbor 23.23.23.2 remote-as 234
 neighbor 23.23.23.2 update-source Ethernet0/0
 neighbor 23.23.23.2 next-hop-self
 neighbor 34.34.34.3 remote-as 234
 neighbor 34.34.34.3 update-source Ethernet0/0
 neighbor 34.34.34.3 next-hop-self
 neighbor 45.45.45.5 remote-as 2
 neighbor 45.45.45.5 ebgp-multihop 5
 neighbor 45.45.45.5 update-source Ethernet0/1
 no auto-summary
!
ip http server
!
!
!
cdp timer 5
cdp holdtime 10
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end
 
 
r5#show run
Building configuration...
Current configuration : 1110 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
no ip domain lookup
!
!        
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.0
!
interface Ethernet0/0
 ip address 45.45.45.5 255.255.255.0
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet0/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 2
 passive-interface Loopback0
 network 5.5.5.0 0.0.0.255
 network 45.45.45.0 0.0.0.255
 no auto-summary
!
router bgp 2
 no synchronization
 bgp router-id 5.5.5.5
 bgp log-neighbor-changes
 network 45.45.45.0 mask 255.255.255.0
 neighbor 45.45.45.4 remote-as 234
 neighbor 45.45.45.4 ebgp-multihop 2
 neighbor 45.45.45.4 update-source Ethernet0/0
 no auto-summary
!
ip http server
!
!
!
cdp timer 5
cdp holdtime 10
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章