Maximum Subsequence Sum 浙大pta 時間複雜度已降到O(n)

 

 

 

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

 

#include <iostream>
#include <stdlib.h>

using namespace std;

int MaxSubseqSum(int aa[],int nn,int *a,int *b)
{
    int thissum=0,maxsum=-1;
    int first=0,end=nn-1,src=nn-1;
    for(int i=0;i<nn;i++)
    {
        thissum+=aa[i];
        if(thissum>maxsum)
        {
           maxsum=thissum;
           src=first;
           end=i; 
        }
            
        else if(thissum<0)
        {
            thissum=0;
            first=i+1;
        }
            
    }
    *a=src;
    *b=end; 
    return maxsum;
}
int main(int argc, char *argv[])
{
  int a[10005];
  int n,res,fi=0,en=0;
  cin>>n;
  for(int i=0;i<n;i++)
  {
      cin>>a[i];
  } 
  res=MaxSubseqSum(a,n,&fi,&en);
  if(res<0)
     cout<<0<<" "<<a[0]<<" "<<a[n-1];
  else
     cout<<res<<" "<<a[fi]<<" "<<a[en];
  //system("PAUSE");	
  return 0;
}

 

結果如下

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章