poj 1201- Intervals

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

Source

Southwestern Europe 2002

思路:

令d[i]表示0到i這個區間內至少要選出d[i]個數,那麼對於每個[ai,bi],有d[bi] - d[ai-1] >= ci,可以看出還有一個隱含條件:0 <= d[i] - d[i-1] <= 1,但是因此d[-1]不能表示,令d[i+1]示0到i這個區間內至少要選出d[i+1]個數,然後d[0] = 0,直接求取最長路就行了。

險些超時,1141ms。

#include <iostream>
#include <cstring>
#include <queue>
#include <cctype>
#include <algorithm>
#define INF 0x3fffffff
#define mem(ar,num) memset(ar,num,sizeof(ar))
#define me(ar) memset(ar,0,sizeof(ar))
#define lowbit(x) (x&(-x))
#define IOS ios::sync_with_stdio(false)
#define DEBUG cout<<endl<<"DEBUG"<<endl;
using namespace std;
struct node{
    int net,to,w;
}no[150050];
int n,a,b,c,mi,ma,cnt,dis[100010],vis[100010],h[150100];
void add(int u,int v,int w){
    no[++cnt].net=h[u];
    no[cnt].to=v;
    no[cnt].w=w;
    h[u]=cnt;
}
void spfa(){
    memset(dis,-0x3f,sizeof dis);
    queue<int>q;
    q.push(mi);
    dis[mi]=0;
    vis[mi]=1;
    while(!q.empty()){
        int u=q.front();q.pop();
        vis[u]=0;
        for(int i=h[u];i;i=no[i].net){
            int vs=no[i].to;int b=no[i].w;
            if(dis[vs]<dis[u]+b){
                dis[vs]=dis[u]+b;
                if(!vis[vs]){
                    q.push(vs);
                    vis[vs]=1;
                }
            }
        }
    }
}
int main(){IOS;
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>a>>b>>c;
        add(a, b+1, c);
        mi=min(mi,a);
        ma=max(ma,b+1);
    }
    for(int i=mi;i<ma;i++){add(i, i+1, 0), add(i+1, i, -1);}
    spfa();
    cout<<dis[ma];
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章