1154 Vertex Coloring (25 分)

A proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10
​4
​​ ), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:
For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.


Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9


Sample Output:
4-coloring
No
6-coloring
No


題目大意:給出一個無向圖,並給出每個頂點所對應的顏色,若每個邊所對應的兩個頂點顏色都不相同,則滿足題意

思路分析:用vector把所有的邊都存起來,把所有的頂點的顏色用set存儲起來(利用set自動去重),枚舉所有邊,檢查是否每條邊的兩個頂點的顏色不同,若都不同則輸出顏色個數,否則輸出No


#include <iostream>
#include <stdio.h>
#include <vector>
#include <set>
using namespace std;
struct edge{
    int n1;
    int n2;
};
int main()
{
    int n,m,k;
    scanf("%d %d",&n,&m);
    vector<edge> v(m);
    for(int i = 0; i < m; i++ )
        scanf("%d %d",&v[i].n1,&v[i].n2);
    scanf("%d",&k);
    while(k--){
        int NodeColor[10009];  //注意需要放在while循環內,每次都需要重新利用
        set<int> color;
        for(int i = 0; i < n; i++){
            scanf("%d",&NodeColor[i]);
            color.insert(NodeColor[i]);
        }
        bool flag = true;
        for(int i = 0; i < m; i++){
            if(NodeColor[v[i].n1] == NodeColor[v[i].n2]){
                flag = false;
                break;
            }
        }
        if(flag)
            printf("%d%s\n",color.size(),"-coloring");
        else
            printf("No\n");
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章