km模板-Flow Problem

 

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input

The first line of input contains an integer T, denoting the number of test cases. 
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000) 
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1

Sample Output

Case 1: 1
Case 2: 2
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define pi acos(-1)
const int maxn = 105;
struct network{
	int n;//節點數
	int flow[maxn][maxn];//當前流量
	int cap[maxn][maxn];//容量 
	 void init(int n)
	 {
	 	this->n = n;
	 	memset(cap, 0, sizeof(cap));
	} 
	
	int solve(int s, int t)
	{
		queue<int>q;
		memset(flow, 0, sizeof(flow));
		int ans = 0;//答案 
		int a[maxn];// a[i]表從s到i點的最小殘量
		int p[maxn];//增廣路上一節點
		while(true)
		{
			memset(a, 0, sizeof(a));
			a[s] = inf;
			q.push(s);
			while(!q.empty())
			{
				int u = q.front();
				q.pop();
				for(int i = 1;i <= n;++i)
				{
					if(!a[i] && cap[u][i] > flow[u][i])
					{
						p[i] = u;
						q.push(i);
						a[i] = min(a[u], cap[u][i] - flow[u][i]);
					}
				}	
			}	
			if(a[t] == 0)break;
			for(int u = t;u != s;u=p[u])
			{
				flow[p[u]][u] += a[t];
				flow[u][p[u]] -= a[t];
			}
			ans += a[t];
		}
		return ans;
	}
}gao;
int main()
{
	int t;
	scanf("%d", &t);
	int cnt = 1;
	while(t--)
	{
		int n, m;
		scanf("%d%d", &n, &m);
		gao.init(n);
		while(m--)
		{
			int u, v, w;
			scanf("%d%d%d", &u, &v, &w);
			gao.cap[u][v] += w;
		}
		printf("Case %d: %d\n", cnt++,gao.solve(1,n)); 
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章