PAT 1145 Hashing - Average Search Time

 

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

作者: CHEN, Yue

單位: 浙江大學

時間限制: 200 ms

內存限制: 64 MB

代碼長度限制: 16 KB

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
using namespace std;

bool IsPrime(int n){
    int tag= static_cast<int>(sqrt(n));
    for (int i = 2; i <=tag ; ++i) {
        if ((n%i)==0){
            return false;
        }
    }
    return true;
}

/**
 * 把x塞到array中
 * @param array
 * @param m
 * @param x
 */
bool insert(int*array,int m,int x){
    for (int i = 0; i < m; ++i) {
        int index=(i*i+x%m)%m;
        if (array[index]==-1){
            array[index]=x;
            return true;
        }
    }
    return false;
}

int check(const int* array,int m,int x){
    int count=0;
    for (int i = 0; i <= m; ++i) {//注意這裏爲小於等於
        int val=array[(x%m+i*i)%m];
        count++;
        if (val==x||val==-1){
            break;
        }
    }
    return count;
}
int main() {
    int mSize,n,m;
    cin>>mSize>>n>>m;
    while (!IsPrime(mSize)){
        mSize++;
    }
    int array[mSize];
    vector<int> vector1;
    memset(array,-1, sizeof(array));
    for (int i = 0; i < n; ++i) {
        int num;
        cin>>num;
        if (!insert(array,mSize,num)){
            vector1.push_back(num);
        }
    }
    int count=0;
    for (int j = 0; j < m; ++j) {
        int x;
        cin>>x;
        count+=check(array,mSize,x);
    }
    for(int x:vector1){
        cout<<x<<" cannot be inserted."<<endl;
    }
    double res=count/(double)m;
    printf("%.1f",res);
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章