PAT 1072 Gas Station

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution
#include <iostream>
#include <cstring>
#include <vector>
#include <climits>
#include <algorithm>
#include <cmath>
using namespace std;
int N,M,K,D;
int totalNum;
int graph[1015][1015];
//vector<vector<int>> graph;
struct Sol{
    int id;
    double average;
    double minDis;
};
vector<Sol*> sols;
bool cmp(Sol* s1,Sol* s2){
    if(s1->minDis!=s2->minDis){
        return s1->minDis>s2->minDis;
    }
    if(abs(s1->average - s2->average) >= 1e-2){
        return s1->average<s2->average;
    }
    return s1->id<s2->id;
}
int strToInt(string& s){
    if(s[0]!='G'){
        return stoi(s);
    } else{
        s=s.substr(1);
        return stoi(s)+N;
    }
}
void Dij(int start){
    bool visited[totalNum+1];
    int dist[totalNum+1];
    memset(visited, false, sizeof(visited));
    fill(dist,dist+totalNum+1,INT_MAX);
    dist[start]=0;
    for (int k = 0; k < totalNum; ++k) {
        int minVal=INT_MAX;
        int index=0;
        for (int i = 1; i <=totalNum ; ++i) {
            if(!visited[i]&&dist[i]<minVal){
                minVal=dist[i];
                index=i;
            }
        }
        visited[index]=true;
        for (int i = 1; i <=totalNum ; ++i) {
            if(!visited[i]&&graph[index][i]!=-1){
                if(dist[i]>(dist[index]+graph[index][i])){
                    dist[i]=dist[index]+graph[index][i];
                }
            }
        }
    }
    int minDis=INT_MAX;
    double sum=0;
    for (int i = 1; i <=N; ++i) {
        if(dist[i]<minDis){
            minDis=dist[i];
        }
        sum+=dist[i];
        if(dist[i]>D){
            return;
        }
    }
    Sol* sol=new Sol();
    sol->id=start;
    sol->average=1.0*sum/N;
    sol->minDis=minDis;
    sols.push_back(sol);
}
int main() {
    cin>>N>>M>>K>>D;
    totalNum=N+M;
    memset(graph,-1, sizeof(graph));
    for (int i = 0; i < K; ++i) {
        string s1,s2;
        int val;
        cin>>s1>>s2>>val;
        int a1=strToInt(s1);
        int a2=strToInt(s2);
        graph[a1][a2]=val;
        graph[a2][a1]=val;
    }
    for (int i = 1; i <= M; ++i) {
        Dij(N+i);
    }
    sort(sols.begin(),sols.end(),cmp);
    if(sols.empty()){
        cout<<"No Solution"<<endl;
        return 0;
    }
    Sol* sol=sols[0];
    cout<<"G"<<sol->id-N<<endl;
    printf("%.1f %.1f\n",sol->minDis,sol->average);
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章