1070. Mooncake (25)【貪心】——PAT (Advanced Level) Practise

題目信息

1070. Mooncake (25)

時間限制100 ms
內存限制65536 kB
代碼長度限制16000 B

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45

解題思路

貪心即可

AC代碼

#include <cstdio>
#include <algorithm>
using namespace std;
struct Node{
    double num, value, per;
    bool operator<(const Node& b) const{
        return per > b.per;
    }
}node[1005];
int main()
{
    int n;
    double v;
    scanf("%d%lf", &n, &v);
    for (int i = 0; i < n; ++i){
        scanf("%lf", &node[i].num);
    }
    for (int i = 0; i < n; ++i){
        scanf("%lf", &node[i].value);
        node[i].per = node[i].value / node[i].num;
    }
    sort(node, node + n);
    int p = 0;
    double s = 0;
    while (v > 0 && p < n){
        if (node[p].num > v){
            s += v * node[p].per;
            v -= v;
        }else{
            s += node[p].value;
            v -= node[p].num;
        }
        ++p;
    }
    printf("%.2f\n", s);
    return 0;
}

個人遊戲推廣:
《10雲方》與方塊來次消除大戰!

發佈了184 篇原創文章 · 獲贊 9 · 訪問量 28萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章