PAT A1025. PAT Ranking

1025. PAT Ranking (25)

時間限制
200 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

這一題開始有點棘手,參考算法筆記,看懂後其實挺簡單的

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

//定義學生結構體 
struct Student{
	char id[15];         //准考證號 
	int score;			//分數 
	int location_number;//考場號 
	int local_rank;		//考場內排名 
}stu[30010];

//定義sort比較規則 
bool cmp(Student a,Student b){
	if(a.score != b.score){
		return a.score > b.score;//可以理解爲a.score>b.score時,a放在b前面 
	}
	else{
		return strcmp(a.id,b.id) < 0;//分數相同比較准考證號大小,從小到大 
	}
} 

int main(){
	int n,k,num = 0;
	scanf("%d",&n);
	for(int i=1; i<=n; i++){
		scanf("%d",&k);
		//讀入每個班成績 
		for(int j=0; j<k; j++){
			scanf("%s %d",stu[num].id,&stu[num].score);//字符串不加& 
			stu[num].location_number = i;
			num++;
		}
		sort(stu + num - k,stu + num,cmp);//對該場考生排名
		stu[num-k].local_rank = 1;//該考場第一名在考場內排名第一
		//記錄該考場剩餘考生的local_rank
		for(int j=num-k+1; j<num ;j++){
			if(stu[j].score == stu[j-1].score){
				stu[j].local_rank = stu[j-1].local_rank;//分數相同,當場排名相同 
			}
			else{
				stu[j].local_rank = j+1-(num-k);//注意不要寫是上一個排名+1,排名相同會跳過 
		 	} 
		} 

	}
	printf("%d\n",num);//輸出總考生數
	sort(stu,stu+num,cmp);//全部考生排序
	int r = 1;
	for(int i=0; i<num; i++){
		if(i>0 && stu[i].score!= stu[i-1].score){
			r = i+1 ;//如果考生和上一個分數不同,更新r爲人數加1 
		}
		printf("%s ",stu[i].id);
		printf("%d %d %d\n",r,stu[i].location_number,stu[i].local_rank); 
	} 
	return 0;
}

發佈了49 篇原創文章 · 獲贊 9 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章