poj 1276 Cash Machine F

題目鏈接如下:http://poj.org/problem?id=1276

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 33411   Accepted: 12097

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

題意:有現今cash,和n種錢幣,每種錢幣有ni個,價值爲di,求各種錢幣組成的不超過cash的最大錢數.......

思路:二進制拆分轉化爲01揹包,或者轉化爲完全揹包都是可以的。

同 hdu2191


#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
const int N = 100000 + 20;

int dp[N];
int  w[N], num[N];
int n, m;

void zero_one_pack(int cost, int weight, int n)
{
    for(int i= n; i >= cost ; i--)
        dp[i] = max(dp[i], dp[i-cost] + weight);
}
void complete_pack(int cost, int weight, int n)
{
    for(int i=cost; i<=n; i++)
        dp[i] = max(dp[i], dp[i-cost] + weight);
}
int multi_pack(int n, int m)
{
    memset(dp, 0, sizeof(dp));
    for(int i = 1 ; i <= n ; i++){
        if(num[i]*w[i] > m)
            complete_pack(w[i], w[i], m);
        else{
            int k = 1;
            while(k < num[i]){
                zero_one_pack(k*w[i], k*w[i], m);
                num[i] -= k;
                k <<= 1;
            }
            zero_one_pack(num[i]*w[i], num[i]*w[i], m);
        }
    }
    return dp[m];
}

int main()
{
    int t;
    while( cin >> m >> n)
	{
        for(int i = 1 ; i <= n ; i++)
            cin >> num[i] >> w[i];
        cout << multi_pack(n, m) << endl;
    }
    return 0;
}



發佈了88 篇原創文章 · 獲贊 60 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章