PAT-A1102. 二叉樹-翻轉 層序、中序輸出

題目鏈接:https://www.patest.cn/contests/pat-a-practise/1102

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

注意根結點序號的獲取方式,根結點不是任何結點的子結點,所以遍歷輸入數據,沒出現過的序號就是根結點。

#include <iostream>
#include <queue>
#include <cstring>
using namespace std;

struct BTree{
    char lchild, rchild;
};

BTree T[12];
bool bt[12];
int nindex = 0;
int num = 0;

void InOrder(char n)
{
    if(n == '-')
        return;
    else{
        InOrder(T[n-'0'].lchild);
        cout << n;
        nindex++;
        if(nindex < num)
            cout << ' ';
        else
            cout << endl;
        InOrder(T[n-'0'].rchild);
    }

}

void LevelOrder(char n, int num)
{
    queue<char> qt;
    qt.push(n);
    while (!qt.empty()) {
        char c = qt.front();
        qt.pop();
        cout << c;
        num--;
        if(num>0)
            cout << " ";
        else
            cout << endl;
        if(T[c-'0'].lchild!='-')
            qt.push(T[c-'0'].lchild);
        if(T[c-'0'].rchild!='-')
            qt.push(T[c-'0'].rchild);
    }
}

int getRoot()
{
    for(int i = 0; i < num; ++i){
        if(!bt[i]){
            return i;
        }
    }
    return 0;
}

int main()
{
    cin >> num;
    memset(bt, 0, sizeof(bt));
    for(int i = 0; i < num; ++i){
        cin >> T[i].rchild >> T[i].lchild;
        if(T[i].rchild!='-')
            bt[T[i].rchild-'0']=true;
        if(T[i].lchild!='-')
            bt[T[i].lchild-'0']=true;
    }
    nindex = 0;
    int root = getRoot();
    LevelOrder('0'+root, num);
    InOrder('0'+root);

    return 0;
}
發佈了23 篇原創文章 · 獲贊 5 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章