PAT-A1099. 二叉樹-中序建樹 層序輸出

題目鏈接:https://www.patest.cn/contests/pat-a-practise/1099

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Alt text

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format “left_index right_index”, provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;

struct BTreeNode
{
    int data;
    int lchild, rchild;

};

BTreeNode T[110];
int val[110], ind;

void CreateByInOrder(int);
void LevelOrder(int, int);

int main(int argc, const char * argv[]) {

    int num;
    cin >> num;
    for(int i = 0; i < num; ++i){
        cin >> T[i].lchild >> T[i].rchild;
    }
    for(int i = 0; i < num; ++i){
        cin >> val[i];
    }

    sort(val, val+num);

    ind = 0;

    CreateByInOrder(0);

    ind = 0;

    LevelOrder(0, num);

    return 0;
}

void CreateByInOrder(int root)
{
    if(root == -1)
        return;
    else{
        CreateByInOrder(T[root].lchild);
        T[root].data = val[ind++];
        CreateByInOrder(T[root].rchild);
    }
}

void LevelOrder(int root, int N)
{
    queue<int> qt;
    qt.push(root);

    while (!qt.empty()) {
        int num = qt.front();
        qt.pop();
        cout << T[num].data;
        ind++;
        if(ind < N)
            cout << " ";
        else
            cout << endl;
        if(T[num].lchild != -1)
            qt.push(T[num].lchild);
        if(T[num].rchild != -1)
            qt.push(T[num].rchild);

    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章