Trailing Zeroes (III)


 

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

感悟:求一個數的n階末尾0的數目,只需連續除以5,每除一次count加上每步除的結果。重要公式(記住就行)。。。。

#include<cstdio>
long long sum(long long n){
    long long ans=0;
    while(n){
        ans+=n/5;
        n=n/5;
    }
    return ans;
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        long long Q;
        scanf("%lld",&Q);
        long long left=1,right=1000000000;
        long long ans=0;
        while(left<=right){
            long long mid=(right+left)/2;
            if(sum(mid)==Q){
                ans=mid;
                right=mid-1;
            }else if(sum(mid)>Q){
                right=mid-1;
            }else{
                left=mid+1;
            }
        }
        printf("Case %d: ",i);
        if(ans){
            printf("%lld\n",ans);
        }else{
            printf("impossible\n");
        }
    }
    return 0;
}

 

 

 

發佈了36 篇原創文章 · 獲贊 6 · 訪問量 9762
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章