POJ - 3258: River Hopscotch

River Hopscotch     POJ - 3258

Time Limit: 2000MS             Memory Limit: 65536K

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source


題意:

n個石頭,求去除m個石頭後的最小距離的最大值;

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#define ll long long
using namespace std;
ll a[50050];
int n, m, e;
int is(int x) {
    ll pre = 0;
    int xx = 0;
    for (int i = 0; i < n; i++) {
        if (a[i] - pre < x)
            xx++;
        else
            pre = a[i];
    }
    if (xx <= m && e - pre >= x)//保證最後一個石頭和前一個保留石頭的距離大於等於x
        return 1;
    return 0;
}

int main() {
    cin >> e >> n >> m;
    for (int i = 0; i < n; i++)
        scanf("%lld", &a[i]);
    sort(a, a + n);
    int l = 0, r = e, mid;
    while (l < r - 4) {//模糊邊界
        mid = (l + r) / 2;
        if (is(mid))
            l = mid;
        else
            r = mid;
    }
    long long ans = 0;
    for (int i = l; i <= r; i++)//把模糊邊界沒算的算一遍
        if (is(i))
            ans = i;
    cout << ans << endl;
    return 0;
}

中間用模糊邊界處理二分的結束條件,不會寫亂並且不會那麼耗時。


發佈了26 篇原創文章 · 獲贊 8 · 訪問量 5858
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章