Poj2689【素數篩選】

/*Prime Distance
Time Limit: 1000MS		Memory Limit: 65536K
Total Submissions: 14957		Accepted: 3965
Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.
Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.
Sample Input

2 17
14 17
Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.
Source

Waterloo local 1998.10.17*/

#include<stdio.h>
#include<string.h>
int L, R, prime[100010];
void getprime()              //篩選1~100010的素數
{
    memset(prime, 0, sizeof(prime));
    for(int i = 2; i < 100010; ++i)
    {
        if(!prime[i])
            prime[++prime[0]] = i;     //保存素數
        for(int j = 1; j <= prime[0] && prime[j] <= 100010/i; ++j)
        {
            prime[i*prime[j]] = 1;    //素數的倍數爲非素數
            if(i % prime[j] == 0)    //優化
                break;              //如果i爲某個素數的倍數則不必再×後面的素數
                                  //因爲i×後面大的素數 = 比i大的數×前面小的素數
        }
    }
}
int prime2[1000010], notprime[1000010];//區間相差不會超過1000000數量級
void getprime2()
{
    memset(notprime, 0, sizeof(notprime));
    if(L < 2)                            //1不是素數,爲保證下方prime2的最小素數爲2
    L = 2;
    for(int i = 1; i <= prime[0] && (long long)prime[i]*prime[i] <= R; i++)//篩選出非素數
    {
        int s = L/prime[i] + (L%prime[i] > 0 );//保證j*prime[i]從比L大的地方開始
        if(s == 1)
        s = 2;
        for(int j = s; (long long)j*prime[i] <= R; ++j)
        {
        //    if((long long) j*prime[i] >= L)  //此步可有可無
                notprime[j*prime[i]-L] = 1;
        }
    }
    prime2[0] = 0;
    for(int i = 0; i <= R-L; ++i)
    {
        if(!notprime[i])              //當i= 0時,L必須爲2作爲第一個素數
        prime2[++prime2[0]] = i+L;     //保存L~R的素數
    }
}
int main()
{
    int i, j, k;
    getprime();
    while(scanf("%d%d", &L, &R) != EOF)
    {
        getprime2();
        int x1 = 0, x2 = 100000010, y1 = 0, y2 = 0;
        if(prime2[0] < 2)
        printf("There are no adjacent primes.\n");
        else
        {
            for(i = 1; i < prime2[0]; ++i)
            {
                if(prime2[i+1] - prime2[i] < x2-x1)
                {
                    x2 = prime2[i+1];
                    x1 = prime2[i];
                }
                if(prime2[i+1] - prime2[i] > y2-y1)
                {
                    y2 = prime2[i+1];
                    y1 = prime2[i];
                }
            }
            printf("%d,%d are closest, %d,%d are most distant.\n", x1,x2,y1,y2);
        }
    }
    return 0;
}

發佈了250 篇原創文章 · 獲贊 3 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章