Hduoj1036【水題】

/*Average is not Fast Enough!
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4785    Accepted Submission(s): 1937


Problem Description
A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to 
evaluate the results of a relay race. 

You have to process several teams. For each team you are given a list with the running times for every section of the race. You 
are to compute the average time per kilometer over the whole distance. That's easy, isn't it? 
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm 
participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after 
the contest is over.

 

Input
The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. 
You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team 
number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a 
single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, 
respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the 
data on every line is terminated by a newline character. Input is terminated by EOF.

 

Output
For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for 
this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-"
 instead. Adhere to the sample output for the exact format of presentation.

 

Sample Input
2 12.5
  5 0:23:21 0:25:01
 42 0:23:32 -:--:--
  7 0:33:20 0:41:35
 

Sample Output
  5: 3:52 min/km
 42: -
  7: 6:00 min/km
 

Source
University of Ulm Local Contest 2001 
 

Recommend
We have carefully selected several similar problems for you:  1039 1037 1038 1048 1062 
*/
#include<stdio.h>
#include<string.h>
int main()
{
	int i, j, k, n;
	double dis;
	scanf("%d%lf", &n, &dis);
	int num;
	while(scanf("%d", &num) != EOF)
	{
		int sum = 0, ok = 0;
		for(i = 0; i < n; ++i)
		{
			char s[15];
			scanf("%s", s);
			if(s[0] == '-')
			ok = 1;
			else
			{
				sum += (s[0] - '0') * 3600;
				sum += ( (s[2] - '0') * 10 + (s[3] - '0') ) * 60;
				sum += (s[5] - '0') * 10 + s[6] - '0';
			}
		}
		if(ok)
		{
			printf("%3d: -\n", num);
			continue;
		}
		double ans = (double)sum / dis;
		ans += 0.5;
		printf("%3d:%2d:%02d min/km\n", num, (int)ans / 60, (int)ans % 60); 
	}
	return 0;
}


題意:給出接力賽的段數和總長度,並且給出每個參賽隊伍的編號和每一段的完成時間,求每個小組的完成比賽的平均時間。

思路:題意就是模擬,將小時和分鐘轉換爲秒,計算每秒的速度,接着再轉換爲分鐘:秒的形式,這裏有很多細節問題,首先要注意的是題目給的輸入格式是定死的-:--:--,所以對於輸入處理來說算是一個福利,按照它的格式只要取字符串的固定位置即可計算總時間,最後就是輸出格式,也是定死的,m:ss,這裏要注意的是分鐘位佔2列,其次就是秒位也是2列,如果不足2位要在左邊補0,而分鐘位不需要補0,只要空格就好。最後處理好,被取消參賽資格的情況就ok了。

發佈了250 篇原創文章 · 獲贊 3 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章