poj 1201 Intervals

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.
Write a program that:
reads the number of intervals, their end points and integers c1, ..., cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

Source


/**
    題意:給出n個閉區間[ai,bi],每個區間對應一個ci,
                表示集合Z在區間[ai,bi]內ci個相同元素,
                問集合Z至少有幾個元素。
    分析 :差分約束入門。
                如果我用Si表示區間[0,i]區間內至少有多少個元素的話,
                那麼Sbi - Sai >= ci,這樣我們就構造出來了一系列邊,權值爲ci,
                但是這遠遠不夠,因爲有很多點依然沒有相連接起來,
                不難寫出0<=Si - Si-1<=1的限制條件。
                我們將上面的限制條件寫爲同意的形式:
                Sbi - Sai >= ci
                Si - Si-1 >= 0
                Si-1 - Si >= -1
                對於 b - a > c , addedge(a,b,c);
     */
#include <stdio.h>
#include <algorithm>
#include<cstring>
#include <iostream>
#include<queue>
using namespace std;
const int N = 50010;
const int INF = 1<<30;
int mn = INF,mx = -1;
int d[N],first[N],v[N<<2],w[N<<2],next[N<<2];
char inq[N];
int p = 0;
void Bellman_Ford()
{
    for(int i=mn; i<=mx; i++)d[i]=-INF;
    d[mn] = 0;
    queue<int>q;
    q.push(mn);
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        inq[u]=0;
        for(int i=first[u]; i!=-1; i=next[i])
        {
            if(d[v[i]] < d[u]+w[i])
            {
                d[v[i]] = d[u]+w[i];
                if(!inq[v[i]])
                {
                    inq[v[i]]=1;
                    q.push(v[i]);
                }
            }
        }
    }
}
void addedge(int a, int b, int k)
{
    v[++p] = b;
    next[p] = first[a];
    first[a] = p;
    w[p] = k;
}
int main()
{
    //freopen("date.in","r",stdin);
    int i,j,k,m,n,a,b;
    memset(first,-1,sizeof(first));
    scanf("%d",&n);
    for(i=1; i<=n; i++)
    {
        scanf("%d %d %d",&a,&b,&k);
        b++;
        mn = min(mn,a), mx = max(mx,b);
        addedge(a,b,k);
    }
    for(i=mn; i<mx; i++)
        addedge(i,i+1,0), addedge(i+1,i,-1);
    Bellman_Ford();
    printf("%d\n",d[mx]);
}


發佈了56 篇原創文章 · 獲贊 2 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章