K - Co-prime HDU - 4135

Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N. 
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
InputThe first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9). OutputFor each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below. Sample Input
2
1 10 2
3 15 5
Sample Output
Case #1: 5
Case #2: 10


        
  
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}. 


#include<iostream>
#include<stdio.h>
using namespace std;
typedef long long ll;
const int maxn=10005;
int d[maxn],q[maxn],cnt;
ll ans;
ll IAE(ll m){
    ll sum=0;int n=0;q[n++]=-1;
    for(int i=0;i<cnt;i++){
        int tmp=n;
        for(int j=0;j<tmp;j++)
            q[n++]=q[j]*d[i]*(-1);
    }
    for(int i=1;i<n;i++)
        sum+=m/q[i];
    return sum;
}
int main(){
    int t;scanf("%d",&t);
    for(int c=1;c<=t;c++){
        ll a,b;int n;cnt=0;
        scanf("%lld%lld%d",&a,&b,&n);
        for(int i=2;i*i<=n;i++){
            if(n%i==0){
                while(n%i==0) n/=i;
                d[cnt++]=i;
            }
        }
        if(n!=1) d[cnt++]=n;
        ans=b-IAE(b)-a+1+IAE(a-1);
        printf("Case #%d: %lld\n",c,ans);
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章