ACM暑期集訓 同餘定理+逆元 大數取餘

表面上看這道題是問a能不能整除b,實際上還是看二者取余余數是否爲0,屬於大數取餘的範圍

a的範圍達到10的200次方,用 long long都已經不可以,需要用字符串,而b可以用long long

題目:

F - Large Division

 

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

代碼:(關鍵就是那一步,研究懂就可以)

#include <stdio.h>
#include <string.h>
typedef long long ll;
int main()
{
	int t,k=0,i;
	scanf("%d",&t);
	while(t--)
	{
		char s[1000];
		k++;
		long long b;
		scanf("%s%lld",s,&b);
		int len=strlen(s);
		ll num=0;
		for(i=0;i<len;i++)
		{
			if(s[i]=='-')
			continue;
			num=(num*10+s[i]-'0')%b;//關鍵步驟
		}
		if(num==0) 
		printf("Case %d: divisible\n",k);
		else
		printf("Case %d: not divisible\n",k);
	}
	return 0;
 } 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章