FZU Problem 2271 X(最短路)

Problem Description

X is a fully prosperous country, especially known for its complicated transportation networks. But recently, for the sake of better controlling by the government, the president Fat Brother thinks it’s time to close some roads in order to make the transportation system more effective.

Country X has N cities, the cities are connected by some undirected roads and it’s possible to travel from one city to any other city by these roads. Now the president Fat Brother wants to know that how many roads can be closed at most such that the distance between any two cities in country X does not change. Note that the distance between city A and city B is the minimum total length of the roads you need to travel from A to B.

Input

The first line of the date is an integer T (1 <= T <= 50), which is the number of the text cases.

Then T cases follow, each case starts with two numbers N, M (1 <= N <= 100, 1 <= M <= 40000) which describe the number of the cities and the number of the roads in country X. Each case goes with M lines, each line consists of three integers x, y, s (1 <= x, y <= N, 1 <= s <= 10, x is not equal to y), which means that there is a road between city x and city y and the length of it is s. Note that there may be more than one roads between two cities.

Output

For each case, output the case number first, then output the number of the roads that could be closed. This number should be as large as possible.

See the sample input and output for more details.

Sample Input

2
2 3
1 2 1
1 2 1
1 2 2
3 3
1 2 1
2 3 1
1 3 1
Sample Output

Case 1: 2
Case 2: 0
題意;給你n個點m條無向邊。問你在保證任意兩點最短距離不變的前提下,最多可以刪去幾條邊。
題解:首先重邊和較大邊(兩個城市由兩條邊相連,則較大邊可以刪除)是一定可以刪除的,對剩下的邊跑Floyd,得到任意兩點之間的最短路,然後開始判斷。對於任意兩點x,y,如果兩點間的最短路<兩點間的實際相連邊,則相連邊可以刪除。如果兩點間的最短路就是實際相連邊,並且能找到一個點k使得xy==xk+ky。則xy這條邊可以刪除。
代碼:

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<vector>
#include<queue>
#include<algorithm>
#include<map>
using namespace std;
typedef long long int ll;
typedef pair<int,int>pa;
const int N=1e5+10;
const int MOD=1e9+7;
const ll INF=1e18;
const int inf=20;
int read()
{
    int x=0;
    char ch = getchar();
    while('0'>ch||ch>'9')ch=getchar();
    while('0'<=ch&&ch<='9')
    {
        x=(x<<3)+(x<<1)+ch-'0';
        ch=getchar();
    }
    return x;
}
/************************************************************/
int t,x,y,z;
int n,m;
int mp[120][120];
int b[120][120];
int main()
{
    scanf("%d",&t);
    for(int o=1; o<=t; o++)
    {
        int ans=0;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
                mp[i][j]=(i==j)?0:inf;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(mp[x][y]!=inf) ans++;
            if(mp[x][y]>z)
            {
                mp[x][y]=mp[y][x]=z;
            }
        }
        memcpy(b,mp,sizeof(b));
        for(int k=1; k<=n; k++)
            for(int i=1; i<=n; i++)
                for(int j=1; j<=n; j++)
                    if(mp[i][k]+mp[k][j]<mp[i][j]) mp[i][j]=mp[i][k]+mp[k][j];
        for(int i=1; i<=n; i++)
            for(int j=i+1; j<=n; j++)
                for(int k=1; k<=n; k++)
                {
                    if(mp[i][j]<b[i][j]&&b[i][j]!=inf)
                    {
                        ans++;
                        break;
                    }
                    if(mp[i][j]==mp[i][k]+mp[k][j]&&b[i][j]!=inf&&j!=k&&i!=k)
                    {
                        ans++;
                        break;
                    }
                }
        printf("Case %d: %d\n",o,ans);
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章