PKU-1012 Joseph (約瑟夫環)

原題鏈接 http://poj.org/problem?id=1012

Joseph

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30

Source Code

/*
題目數據量太小,直接模擬Joseph暴力打表也能過。這裏介紹一下遞推法測試。
先引入Joseph遞推公式,設有n個人(0,...,n-1),數m,則第i輪出局的人爲f(i)=(f(i-1)+m-1)%(n-i+1),f(0)=0;
依次我們可以來做測試,只要前k輪中只要有一次f(i)<k則此m不符合題意。
接下來我們考察一下只剩下k+1個人時候情況,那麼依題意則這一輪出局的人要麼在上一輪出局人的左邊,要麼就在右邊,
設上一輪出局的人爲x,則必有m%(k+1)==0或1(還不明白就看下面兩個序列表示的k+2人的情況(G表示好人,共有k個,B表示壞人,
X表示上一輪出局的人)GG....GGBX,GG...GGXB)。所以測試數爲t(k+1)或t(k+1)+1,t>=1。
*/
#include<iostream>
using namespace std;

bool checkIsOk(int k, int m) {
	int i, executed;
	int n = 2 * k;
	executed = 0;
	for (i = 0; i < k; i ++) {
		executed = (executed + m - 1) % (n - i);
		if (executed < k) {
			return false;
		}
	}
	return true;
}

int main() {
	int result[20];
	int i, k, position;
	int m;

	for (i = 0; i < 14; i++) {
		m = i + 1;
		while(1) {
			if (checkIsOk(i, m)){
				result[i] = m;
				break;
			}
			if (checkIsOk(i, m + 1)) {
				result[i] = m + 1;
				break;
			}
			m += (i + 1);
		}
	}

	while (scanf("%d", &k) != EOF) {
		if (k == 0){
			break;
		}

        printf("%d\n", result[k]);
	}
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章