PKU-1001 Exponentiation(浮點數相乘)

原題鏈接 http://poj.org/problem?id=1001

Exponentiation

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
Source Code
/*
高精度乘法:

算法思想:

  1、小數先轉化成整數,並去掉小數末尾的0
  2、整數模擬相乘(利用整型數組存儲結果),每一位乘以乘數,結果%10存在當前位,結果/10作爲進位
  3、考慮多種情況倒序輸出結果

*/

#include <iostream>
using namespace std; 

int result[1000];

/*字符串轉化爲整數*/
int strToInt(char *ch, int &digit) {
    
	int i;
	int num = 0;
	bool afterPoint = false;
	
	for (i = 0; ch[i] != '\0'; i++) {
		if (ch[i] == '.') {
			afterPoint = true;
		} else {
			num = num * 10;
			num += (ch[i] - '0');
			if (afterPoint) {
				digit ++;
			}
		}		
	}

	/*如果小數末尾存在0,去除*/
	int len = i;
	if (afterPoint) {
		for (i = len - 1; i >=0 ; i--) {
			if (ch[i] == '0') {
				num = num / 10;
				digit --;
			} else {
				break;
			}
		}
	}
	
	return num;
}

int main() {

	char num_ch[10];
	int i, j;
	int exponent, digit, num, len;

	while(scanf("%s %d", num_ch, &exponent)!=EOF) {

		digit = 0;
		len = 0;
        num = strToInt(num_ch, digit);
 
		int temp = num;
		while (temp != 0) {
			result[len ++] = temp % 10;
			temp /= 10; 
		}
 
		//模擬相乘exponent-1次
		int ret = 0;
		for (i = 0; i < exponent - 1; i ++) {
			ret = 0;
			for (j = 0; j < len; j ++) {
				 temp = result[j] * num + ret;
			     result [j] = temp % 10;
				 ret = temp / 10;
			}
            while (ret != 0) {
				result[len ++] = ret % 10;
				ret /= 10;
			}
		}

		//輸出結果
		if (!digit) {
			for (i = len - 1; i >= 0; i--) {
				printf("%d",result[i]);
			}
		} else if (len <= digit * exponent) {
			printf(".");
			for (i = digit * exponent - len; i > 0; i--){
				printf("0");
			}
			for (i = len - 1; i >= 0; i--) {
				printf("%d", result[i]);
			}
		} else {
			for (i = len - 1; i > digit * exponent - 1; i--) {
				printf("%d", result[i]);
			}
			printf(".");
			for (; i >= 0; i--) {
				printf("%d", result[i]);
			}
		}
		printf("\n");
	}

}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章