Sicily 1305 Who’s Winner?

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Nic and Susan play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Nic always starts with p=1, does his multiplication. Then Susan multiplies the number, then Nic and so on. Before a game starts, they draw an integer 1≤n<4,294,967,295 and the winner is who first reaches p≥n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either

Nic wins.

or

Susan wins.

Assume that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Nic wins.
Susan wins.
Nic wins.

Problem Source

ZSUACM Team Member


Solution

這題意有點表述不清,簡單來說就是p=1,然後兩人先後從2-9中取數字乘上p,Nic先手,誰的操作使得p>=n誰就贏。給出n,問誰贏。

從極限觸發列舉情況:

n = [1.9]          Nic Win

n = [10,18]     SuSan Win

n = [19,162]   Nic Win

在列舉的時候可以知道,Nic有希望的時候就是9*2*9,會取9,而Susan會選2來阻止,同理,當SuSan有希望的時候是2*9*2*9,Nic會取2來阻止。

歸納後模擬就ok啦~


#include <cstdio>

int main()
{
  long long n;

  while (scanf("%lld", &n) == 1)
  {
    long long p = 1;

    while (p)//模擬
    {
      p *= 9;
      if (p >= n)
      {
        printf("Nic wins.\n");
        break;
      }
      p *= 2;
      if (p >= n)
      {
        printf("Susan wins.\n");
        break;
      }
    }
  }

  return 0;
}





發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章