ZOJ2855 Google Map java

題目鏈接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2855

                                      Google Map

GoogleMap is a useful tool and most of you should be familiar with it. As the best hacker in the world, Jack is planning to retrieve all the data on the GoogleMap server. But he soon gives up because the total amount of data exceeds 1000T bytes! But he has learnt the way in which Google stores their data on the server, and he turns to download only the parts that he's interested in. Here is the representation of the data that Jack has found:

First of all, you should know the basic background knowledge of GIS (Geography Information System). In GoogleMap, the whole world is represented in a whole flat image transformed from the surface of the earth by Mercator projection. The Mercator projection is a map projection which is widely used for navigation. The following equations place the x-axis of the projection on the equator (from West to East) and the y-axis at longitude 0 (from South to North)

  • x = longitude * pi / 180;
  • y = ln(tan(pi / 4 + (latitude * pi / 180) / 2))

Here, the latitude is between [-85, 85] (negative for South) and the longitude is between [-180, 180] (negative for West) The left of the map image is W180 and the right is E180. The top of the map image is N85 and the bottom is S85. The maps have different levels. In the first level, the whole image consists of only one tile with tag name "t". For each tile in one level, it will be clipped into 4 equally sized parts and magnified by 2 in the next level.

                                        

And the new tag name for the tiles in the next level will be the tag of their parent tile followed by the identifier of the clip area in the parent tile. (that is, q for left-top, r for right-top, t for left-bottom, s for right-bottom) For example:

                                   

So there will be 4L tiles in level L (Assume the first level is labeled as level 0). More interestingly, the filename of the tile on the server is just the tag name. Although Jack is very genius, he doesn't know any programming language, so he turns to you for writing a tool to generate the tags for him.

Input

The input contains multiple test cases!

In each case, there will be three numbers. The first two are the coordinates that indicate the longitude and latitude of the interested location, and the third is the level number required by Jack.

The longitude is between [-180, 180] (negative for West) and the latitude is between [-85, 85] (negative for South)

Output

Output the tag for the tile in the specified level that contains the location in a single line.

You can assume that the location will not be at the boundary of any tiles.

Sample Input

80 33 2
-80 -33 4
72.12 46.68 10

Sample Output

trt
ttrqt
trtrstqsrqs

Notes

You can use the 'log(double)' function to calculate the natural logarithm, and 'tan(double)' to calculate the tangent value. Both of these functions are included in the header '<math.h>' for C or '<cmath>' for C++.

題意:

一個地圖,輸入三個值的最後一個值L,代表要把這個地圖分成 4^L 份,每一次分 就是把整個地圖的每一份小地圖分成四份,左上的在其名字後面加上一個字母q,右上的r,左下的t,右下的s,給出兩個值。

思路:

先把經緯度轉化爲圖像上的座標值,經度投影到以赤道所在的x軸上,緯度投影到以東經0度所在的y軸上,然後根據題目要求,看落在哪塊,哪塊就作爲其邊界值。

代碼:

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;

public class Zoj2855 {
	public static void main(String[] args){
		StreamTokenizer sc = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
		try{
			while(sc.nextToken()!=StreamTokenizer.TT_EOF){
				double top=latitude(85);
				double down=latitude(-85);
				double left=-180*Math.PI/180;
				double right=180*Math.PI/180;
				String s="t";
				double x=sc.nval;
				sc.nextToken();
				double y=sc.nval;
				sc.nextToken();
				x=x*Math.PI/180;
				y=latitude(y);
				int lever =(int)sc.nval;
				while(lever-->0){
					double midx=(left+right)/2;
					double midy=(top+down)/2;
					if(x > midx){
						left = midx;
					       if(y > midy){
					           down = midy;
					           s+="r";
					       }else{
					           top = midy;
					           s+="s";
					       }
					    }else{
					       right = midx;
					       if(y > midy){
					           down = midy;
					           s+="q";
					       }else{
					           top = midy;
					           s+="t";
					       }
					    }
				}
				System.out.println(s);
			}
		}catch (IOException e) {
			// TODO Auto-generated catch block
			e.printStackTrace();
		}
	}
	static double latitude(double d){
		return Math.log10(Math.tan(Math.PI/4+(d*Math.PI/180)/2));
	}
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章