ZOJ2850 Beautiful Meadow java

題目鏈接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2850

                                  Beautiful Meadow

                                                       

Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

  1. Not all squares are covered with grass.
  2. No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

Input

The input contains multiple test cases!

Each test case starts with a line containing two integers NM (1 <= NM <= 10) separated by a space. There follows the description of Tom's Meadow. There're N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

Output

One line for each test case.

Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

Sample Input

2 2
1 0
0 1
2 2
1 1
0 0
2 3
1 1 1
1 1 1
0 0

Sample Output

Yes
No
No

題意:

Tom有一片花園,初始所有方塊的覆蓋草,你需要除草使它成爲最美花園,有2個條件。

1:不能所有的方塊都覆蓋草。

2:不能兩個相鄰的方塊覆蓋草。

數字0意味着草地是修剪過的,數字1意味着是草覆蓋的。

思路:

首先判斷所有方塊是不是覆蓋草,如果有修建的,就判斷是否相鄰兩個是修建過的,如果是則返回NO,否則YES。

代碼:

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			int n=sc.nextInt();
			int m=sc.nextInt();
			if(n==0&&m==0){
				break;
			}
			boolean flag=false;
			int a[][]=new int[n][m];
			for(int i=0;i<n;i++){
				for(int j=0;j<m;j++){
					a[i][j]=sc.nextInt();
				}
			}
			for(int i=0;i<n;i++){
				for(int j=0;j<m;j++){	//判斷是否修剪過,修建過就是true
					if(a[i][j]==0){
						flag=true;
						break;
					}
				}
				if(flag==true)break;
			}
			for(int i=0;i<m-1&&flag==true;i++){	//判斷有沒有相鄰的修建的方塊
				if(a[0][i]==0&&a[0][i+1]==0){
					flag=false;
				}
			}
			for(int i=0;i<n-1&&flag==true;i++){ //判斷有沒有相鄰的修建的方塊
				if(a[i][0]==0&&a[i+1][0]==0){
					flag=false;
				}
			}
			for(int i=1;i<n&&flag==true;i++){
				for(int j=1;j<m;j++){
					if((a[i][j]==0&&a[i-1][j]==0)||(a[i][j]==0&&a[i][j-1]==0)){ //判斷有沒有相鄰的修建的方塊
						flag=false;
						break;
					}
				}
			}
			if(flag==true){
				System.out.println("Yes");
			}
			else{
				System.out.println("No");
			}
		}
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章