Avoid The Lakes

Problem Description
Farmer John’s farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest “lake” on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input
* Line 1: Three space-separated integers: N, M, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output
* Line 1: The number of cells that the largest lake contains. 

Sample Input
3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output
4

#include<stdio.h>
#include<string.h>
#define max 120
int a[max][max];
int dfs(int x,int y)
{
    int sum=1;
    a[x][y]=0;
    if(a[x+1][y]==1)
    sum+=dfs(x+1,y);
    if(a[x-1][y]==1)
    sum+=dfs(x-1,y);
    if(a[x][y-1]==1)
    sum+=dfs(x,y-1);
    if(a[x][y+1]==1)
    sum+=dfs(x,y+1);
    return sum;    
}
int main()
{
    int x,y,n,m,k,t,i,j;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {
        memset(a,0,sizeof(a));
        for(i=1;i<=k;i++)
        {
            scanf("%d%d",&x,&y);
            a[x-1][y-1]=1;
        }
        int maxx=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(a[i][j]==1)
                {
                    t=dfs(i,j);
                    if(t>maxx)
                    maxx=t;
                }
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章